summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-07 17:30:55 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-09-07 17:42:49 +0200
commit5c4a71cc41c2940ae671e38c10eb8dd7fa377880 (patch)
treeed55cf36925918f7c32790345f683c5374df1d75 /dev-python/pyuca/pyuca-1.2.ebuild
parentsys-kernel/gentoo-sources: drop 6.4.12 (diff)
downloadgentoo-5c4a71cc41c2940ae671e38c10eb8dd7fa377880.tar.gz
gentoo-5c4a71cc41c2940ae671e38c10eb8dd7fa377880.tar.bz2
gentoo-5c4a71cc41c2940ae671e38c10eb8dd7fa377880.zip
dev-python/pyuca: new package, add 1.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyuca/pyuca-1.2.ebuild')
-rw-r--r--dev-python/pyuca/pyuca-1.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pyuca/pyuca-1.2.ebuild b/dev-python/pyuca/pyuca-1.2.ebuild
new file mode 100644
index 000000000000..5db289e33535
--- /dev/null
+++ b/dev-python/pyuca/pyuca-1.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Unicode Collation Algorithm"
+HOMEPAGE="
+ https://github.com/jtauber/pyuca
+ https://pypi.org/project/pyuca/
+"
+SRC_URI="
+ https://github.com/jtauber/pyuca/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest