summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-09 08:41:14 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-09 09:26:06 +0200
commit72a66c9f34a3dfe5d4a60f98245ab8ae87c6cafa (patch)
tree9edfc0204eeecedfe15c019c0f82214e23265712 /dev-python/pyusb
parentdev-python/cffi: Bump to 1.14.6 (diff)
downloadgentoo-72a66c9f34a3dfe5d4a60f98245ab8ae87c6cafa.tar.gz
gentoo-72a66c9f34a3dfe5d4a60f98245ab8ae87c6cafa.tar.bz2
gentoo-72a66c9f34a3dfe5d4a60f98245ab8ae87c6cafa.zip
dev-python/pyusb: Bump to 1.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyusb')
-rw-r--r--dev-python/pyusb/Manifest1
-rw-r--r--dev-python/pyusb/pyusb-1.2.1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pyusb/Manifest b/dev-python/pyusb/Manifest
index 0e0c76118052..f4e63d6fb300 100644
--- a/dev-python/pyusb/Manifest
+++ b/dev-python/pyusb/Manifest
@@ -1,2 +1,3 @@
DIST pyusb-1.1.1.tar.gz 74746 BLAKE2B 795acafae3193e1a415baeb634554c8fdec3f4baa45a61a3eac9e1af4a84634cc540d421b7d8ad20142912fbef6ba53684e2e5b008e48f3e89406a493918ab20 SHA512 19aa82dcb9421d536063a975414855d1474f44b33dc4039e9a001be795061dbd60ed576acb605ae6bab7a0fe10834e5507408757546c7edcd50b43687a65a287
DIST pyusb-1.2.0.tar.gz 75557 BLAKE2B 3a2d066d4069a8662c981ab1f01237d7c0bc18be82afb96a79cf861b04e2e389c5d5f6be96bf54337ef0b2ad8043d047554caed83987328d4e453a3748d13bc6 SHA512 3aa6314bd06467cf22fe299d414ffbdea773c8784dccfe53e7d54d238285bc389ba35317a993b38d2b2027c71a990edcf17016a060b8e627fe97e9cfcc99ce7d
+DIST pyusb-1.2.1.tar.gz 75292 BLAKE2B c1b99f22919ab4beb8e96d664147dc51001c4a48b3acf9ba3961f7f53a9d13277c622e891481fd00b9d34d2ed8a2a0932b7949c13396ea4d76b36f36fcc4cdb0 SHA512 51d0c1165540afa21d6d0ab7315ac77b08083d1cb8e502173dfb1766bc542173f9d7b0070fd14bc71d147e31c3f0780b277093791a7c82485962a04ec62bf0f1
diff --git a/dev-python/pyusb/pyusb-1.2.1.ebuild b/dev-python/pyusb/pyusb-1.2.1.ebuild
new file mode 100644
index 000000000000..24e01cf2f163
--- /dev/null
+++ b/dev-python/pyusb/pyusb-1.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="USB support for Python"
+HOMEPAGE="https://pyusb.github.io/pyusb/ https://pypi.org/project/pyusb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+### This version is compatible with both 0.X and 1.X versions of libusb
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+
+DOCS=( README.rst docs/tutorial.rst )
+
+python_test() {
+ cd tests || die
+ "${EPYTHON}" testall.py || die "Tests failed with ${EPYTHON}"
+}