summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-31 06:00:52 +0000
committerSam James <sam@gentoo.org>2020-12-31 06:07:46 +0000
commit87e5e4e2dbb72ff665f4a5075574be4034d601d8 (patch)
treebfa7d934d7661c1e6249fd33f6fc45d8bf1cb703 /dev-python/pyxdg/pyxdg-0.27.ebuild
parentdev-python/peewee: bump to 3.14.0 (diff)
downloadgentoo-87e5e4e2dbb72ff665f4a5075574be4034d601d8.tar.gz
gentoo-87e5e4e2dbb72ff665f4a5075574be4034d601d8.tar.bz2
gentoo-87e5e4e2dbb72ff665f4a5075574be4034d601d8.zip
dev-python/pyxdg: bump to 0.27
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyxdg/pyxdg-0.27.ebuild')
-rw-r--r--dev-python/pyxdg/pyxdg-0.27.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/pyxdg/pyxdg-0.27.ebuild b/dev-python/pyxdg/pyxdg-0.27.ebuild
new file mode 100644
index 000000000000..b348a84228ba
--- /dev/null
+++ b/dev-python/pyxdg/pyxdg-0.27.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="${PN}-rel-${PV}"
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module to deal with freedesktop.org specifications"
+HOMEPAGE="https://freedesktop.org/wiki/Software/pyxdg https://cgit.freedesktop.org/xdg/pyxdg/"
+SRC_URI="https://github.com/takluyver/${PN}/archive/rel-${PV}.tar.gz -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+distutils_enable_tests nose