summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-11-02 14:45:45 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-11-02 14:46:35 +0300
commitcdbb5b6795858e102bc0b7c03fdf65e4ab57e982 (patch)
treef8d87ca1aac882c39f7004887a2efcb2b8c26bad /dev-python/pyyaml/pyyaml-3.13.ebuild
parentmetadata/layout.conf: Disallow RESTRICT=primaryuri (diff)
downloadgentoo-cdbb5b6795858e102bc0b7c03fdf65e4ab57e982.tar.gz
gentoo-cdbb5b6795858e102bc0b7c03fdf65e4ab57e982.tar.bz2
gentoo-cdbb5b6795858e102bc0b7c03fdf65e4ab57e982.zip
Revert "dev-python/pyyaml: remove insecure"
This reverts commit e4b4576d33480b691957813b6e937672ace88591. Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml/pyyaml-3.13.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-3.13.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-3.13.ebuild b/dev-python/pyyaml/pyyaml-3.13.ebuild
new file mode 100644
index 000000000000..244c5cb8505f
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-3.13.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_P="PyYAML-${PV}"
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="https://pyyaml.org/wiki/PyYAML https://pypi.org/project/PyYAML/"
+SRC_URI="https://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="examples libyaml"
+
+RDEPEND="libyaml? ( dev-libs/libyaml )"
+DEPEND="${RDEPEND}
+ libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}