summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2020-01-26 15:10:14 -0600
committerWilliam Hubbs <williamh@gentoo.org>2020-01-26 15:11:14 -0600
commit5168b603b4470cffb279bb407dbbd153febad6bb (patch)
treee538184f8ff4b381a479da5d29af27b52455567d /dev-python/pyyaml/pyyaml-5.3.ebuild
parentx11-libs/libXpm: Drop old versions (diff)
downloadgentoo-5168b603b4470cffb279bb407dbbd153febad6bb.tar.gz
gentoo-5168b603b4470cffb279bb407dbbd153febad6bb.tar.bz2
gentoo-5168b603b4470cffb279bb407dbbd153febad6bb.zip
dev-python/pyyaml: 5.3 bump
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml/pyyaml-5.3.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-5.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-5.3.ebuild b/dev-python/pyyaml/pyyaml-5.3.ebuild
new file mode 100644
index 000000000000..b63569118b84
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-5.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_P="PyYAML-${PV}"
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="https://pyyaml.org/wiki/PyYAML https://pypi.org/project/PyYAML/"
+SRC_URI="https://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="examples libyaml"
+
+RDEPEND="libyaml? ( dev-libs/libyaml )"
+DEPEND="${RDEPEND}
+ libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # bug #659348
+ "${FILESDIR}/pyyaml-5.1-cve-2017-18342.patch"
+)
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_test() {
+ YAML_TEST_VERBOSE=1 esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}