summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-20 23:01:57 +0000
committerSam James <sam@gentoo.org>2021-01-20 23:02:03 +0000
commitfa1134a0a3e13f71d47fe7d3b84590e96eb1be16 (patch)
tree90c09cf0f1f060ff1adc3bd26f07ffda63392f8b /dev-python/pyyaml/pyyaml-5.4.1.ebuild
parentdev-lang/python: stable 2.7.18-r6 for sparc, bug #766189 (diff)
downloadgentoo-fa1134a0a3e13f71d47fe7d3b84590e96eb1be16.tar.gz
gentoo-fa1134a0a3e13f71d47fe7d3b84590e96eb1be16.tar.bz2
gentoo-fa1134a0a3e13f71d47fe7d3b84590e96eb1be16.zip
dev-python/pyyaml: bump to 5.4.1
Bug: https://bugs.gentoo.org/766228 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml/pyyaml-5.4.1.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-5.4.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-5.4.1.ebuild b/dev-python/pyyaml/pyyaml-5.4.1.ebuild
new file mode 100644
index 000000000000..cb18eff64ebb
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-5.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="https://pyyaml.org/wiki/PyYAML
+ https://pypi.org/project/PyYAML/
+ https://github.com/yaml/pyyaml"
+SRC_URI="https://github.com/yaml/pyyaml/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE="examples +libyaml"
+
+BDEPEND="
+ libyaml? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )
+"
+RDEPEND="libyaml? ( dev-libs/libyaml:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ # bug #659348
+ "${FILESDIR}/pyyaml-5.1-cve-2017-18342.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}