summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-10-14 01:03:10 +0200
committerMichał Górny <mgorny@gentoo.org>2015-10-14 08:06:35 +0200
commit5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f (patch)
treef2de3644b75e298ceeaed790daab2aa73e57d62f /dev-python/pyyaml
parentdev-python/setuptools: Partially restore ~arch keywords (diff)
downloadgentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.gz
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.tar.bz2
gentoo-5b6edb4a3b74a81ee8d238aaabe59b8d8ff8246f.zip
dev-python/*: Restore keywords and un-revbump for py3.5
Restore keywords that were removed unnecessarily, and collapse unnecessary revbumps on packages with added python3.5 support.
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/pyyaml-3.11-r1.ebuild42
-rw-r--r--dev-python/pyyaml/pyyaml-3.11.ebuild3
2 files changed, 2 insertions, 43 deletions
diff --git a/dev-python/pyyaml/pyyaml-3.11-r1.ebuild b/dev-python/pyyaml/pyyaml-3.11-r1.ebuild
deleted file mode 100644
index 364e467d29cc..000000000000
--- a/dev-python/pyyaml/pyyaml-3.11-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-
-inherit distutils-r1
-
-MY_P="PyYAML-${PV}"
-
-DESCRIPTION="YAML parser and emitter for Python"
-HOMEPAGE="http://pyyaml.org/wiki/PyYAML https://pypi.python.org/pypi/PyYAML"
-SRC_URI="http://pyyaml.org/download/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE="examples libyaml"
-
-RDEPEND="libyaml? ( dev-libs/libyaml )"
-DEPEND="${RDEPEND}
- libyaml? ( $(python_gen_cond_dep 'dev-python/cython[${PYTHON_USEDEP}]' python2_7 'python3*') )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_configure_all() {
- mydistutilsargs=( $(use_with libyaml) )
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}
- fi
-}
diff --git a/dev-python/pyyaml/pyyaml-3.11.ebuild b/dev-python/pyyaml/pyyaml-3.11.ebuild
index 9e8b6ad7a244..526a65883cbe 100644
--- a/dev-python/pyyaml/pyyaml-3.11.ebuild
+++ b/dev-python/pyyaml/pyyaml-3.11.ebuild
@@ -3,7 +3,8 @@
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
inherit distutils-r1