summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:25 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:25 +0200
commit250f89cc65d8c23aea70b406d222412236d5b613 (patch)
tree5235c669fce0ba1f9c6cbf43eacc6d7c2260667c /dev-python/pyzmq
parentdev-python/pyyaml: Remove redundant versions (diff)
downloadgentoo-250f89cc65d8c23aea70b406d222412236d5b613.tar.gz
gentoo-250f89cc65d8c23aea70b406d222412236d5b613.tar.bz2
gentoo-250f89cc65d8c23aea70b406d222412236d5b613.zip
dev-python/pyzmq: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-19.0.0.ebuild61
2 files changed, 0 insertions, 62 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index 27e02b833185..fc8bb6519626 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,2 +1 @@
-DIST pyzmq-19.0.0.tar.gz 1150320 BLAKE2B a2af57b1cb809ab72aff1bbee17a7fff5eeeff90805884542579c7cb58c235f8b257a8724c64f55cc8e8eda4a943ec2f54490d546a74bc1532557c46b420e6d2 SHA512 06a395fee62c78f806c43b07362fe2d4b7ac05813d75d4b983f8eefffbe0ca36f64db1591ead719b2866fcfe0867c919033eca0063ca32529e649cd9790461b1
DIST pyzmq-19.0.1_p20200608.tar.gz 390927 BLAKE2B d70a2f615782cc5a53ed2ffab4d5549bc5d15cc1e0e63f640a357fe8575ca327a5976a3e8b11d97c236a31ca17025f37fe423d166b684b5c4aafc139a0941492 SHA512 7f077ed3858c226eb1e3f5e51dfb5d4b517ec94357b37cc66d17cfe2543786b86627ce7eb4c12785a2709a499af998d02642d972c119a637df3cec5201e909d1
diff --git a/dev-python/pyzmq/pyzmq-19.0.0.ebuild b/dev-python/pyzmq/pyzmq-19.0.0.ebuild
deleted file mode 100644
index d7ab0d554b02..000000000000
--- a/dev-python/pyzmq/pyzmq-19.0.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit flag-o-matic distutils-r1 toolchain-funcs
-
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="https://www.zeromq.org/bindings:python https://pypi.org/project/pyzmq/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc +draft test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=net-libs/zeromq-4.2.2-r2:=[drafts]
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi:=[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- dev-python/numpydoc[${PYTHON_USEDEP}]
- )"
-
-PATCHES=(
- "${FILESDIR}/pyzmq-19.0.0-tests.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- "dev-python/numpydoc"
-
-python_prepare_all() {
- # Prevent un-needed download during build
- sed -e "/'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- # some tests fail with cffi backend
- rm zmq/tests/asyncio/test_asyncio.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- tc-export CC
- append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
-}
-
-python_compile() {
- esetup.py cython --force
- distutils-r1_python_compile
-}