summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-28 23:02:18 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-28 23:04:50 +0100
commit3635fb57325467c27cf380249690345080c0b082 (patch)
tree454e658e5c99dddea3435587baa72ed348cb0a95 /dev-python/pyzmq
parentpackage.mask: Last rite net-wireless/gr-air-modes (diff)
downloadgentoo-3635fb57325467c27cf380249690345080c0b082.tar.gz
gentoo-3635fb57325467c27cf380249690345080c0b082.tar.bz2
gentoo-3635fb57325467c27cf380249690345080c0b082.zip
dev-python/pyzmq: Remove py2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/pyzmq-16.0.2.ebuild5
-rw-r--r--dev-python/pyzmq/pyzmq-17.1.0.ebuild5
2 files changed, 2 insertions, 8 deletions
diff --git a/dev-python/pyzmq/pyzmq-16.0.2.ebuild b/dev-python/pyzmq/pyzmq-16.0.2.ebuild
index 914737e0cb2b..c6f982a73c26 100644
--- a/dev-python/pyzmq/pyzmq-16.0.2.ebuild
+++ b/dev-python/pyzmq/pyzmq-16.0.2.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="threads(+)"
inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,13 +22,11 @@ RDEPEND="
>=net-libs/zeromq-4.1.2:=
dev-python/py[${PYTHON_USEDEP}]
dev-python/cffi:=[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
"
DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
www-servers/tornado[${PYTHON_USEDEP}]
)
doc? (
@@ -53,7 +51,6 @@ python_compile_all() {
python_compile() {
esetup.py cython --force
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile
}
diff --git a/dev-python/pyzmq/pyzmq-17.1.0.ebuild b/dev-python/pyzmq/pyzmq-17.1.0.ebuild
index 90216948f4ff..e7d8b211d806 100644
--- a/dev-python/pyzmq/pyzmq-17.1.0.ebuild
+++ b/dev-python/pyzmq/pyzmq-17.1.0.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7} )
PYTHON_REQ_USE="threads(+)"
inherit flag-o-matic distutils-r1 toolchain-funcs
@@ -22,13 +22,11 @@ RDEPEND="
>=net-libs/zeromq-4.2.2-r2:=[drafts]
dev-python/py[${PYTHON_USEDEP}]
dev-python/cffi:=[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
"
DEPEND="${RDEPEND}
dev-python/cython[${PYTHON_USEDEP}]
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' -2)
>=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
)
doc? (
@@ -55,7 +53,6 @@ python_compile_all() {
python_compile() {
esetup.py cython --force
- python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
distutils-r1_python_compile
}