summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-03-19 13:01:53 +0100
committerJoonas Niilola <juippis@gentoo.org>2020-03-27 18:25:00 +0200
commitff017e8e52ac7eeec955b27bde34ecca8093e12a (patch)
treeb3d501dd419bb7279f1a9b28ae0cdd7f9a6cc600 /dev-python/qdarkstyle
parentdev-python/python-language-server: version bump 0.31.9 (diff)
downloadgentoo-ff017e8e52ac7eeec955b27bde34ecca8093e12a.tar.gz
gentoo-ff017e8e52ac7eeec955b27bde34ecca8093e12a.tar.bz2
gentoo-ff017e8e52ac7eeec955b27bde34ecca8093e12a.zip
dev-python/qdarkstyle: version bump 2.8
Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/qdarkstyle')
-rw-r--r--dev-python/qdarkstyle/Manifest2
-rw-r--r--dev-python/qdarkstyle/qdarkstyle-2.7.ebuild43
-rw-r--r--dev-python/qdarkstyle/qdarkstyle-2.8.1.ebuild56
3 files changed, 57 insertions, 44 deletions
diff --git a/dev-python/qdarkstyle/Manifest b/dev-python/qdarkstyle/Manifest
index 963ab616a93a..ed582f0bbc8c 100644
--- a/dev-python/qdarkstyle/Manifest
+++ b/dev-python/qdarkstyle/Manifest
@@ -1 +1 @@
-DIST qdarkstyle-2.7.tar.gz 9156490 BLAKE2B 6c1c21c728725f391802b30acb6365dbd073328158fb3a60b4e2b5bb846337149c166ab447b1e84a404b01b4bc41e1292fff974b2a9756c6c42f4b40754c9a0b SHA512 6185cb85009d62a74021c3267039c6309757909903d67a1b67315877b84d4ffbc468f49cbe54ca4c7319710ea74652a3013e574698d2037cc4f2d83c9fb2b28e
+DIST qdarkstyle-2.8.1.tar.gz 7883937 BLAKE2B fd5a35467c6c47e9eb135d4a119b3f382bfe20b9b0ac2d407fef7113e5ce4d914f3d8e462d26a71b8f1494f42b71a4f8819b0eb2c6579d87ca9dd497d09d39d7 SHA512 10c3f834b1ea50f665c2ce3fde16533c7dfc62c2d055afcc7d2434c09d14fb9a6181b73ce12d3af72897b9d26b41db81cc76e7c7cb6112eef097cd86630b6532
diff --git a/dev-python/qdarkstyle/qdarkstyle-2.7.ebuild b/dev-python/qdarkstyle/qdarkstyle-2.7.ebuild
deleted file mode 100644
index ef8b2be9d963..000000000000
--- a/dev-python/qdarkstyle/qdarkstyle-2.7.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit eutils distutils-r1
-
-MY_PN="QDarkStyleSheet"
-
-DESCRIPTION="A dark style sheet for QtWidgets application"
-HOMEPAGE="https://github.com/ColinDuquesnoy/QDarkStyleSheet"
-SRC_URI="https://github.com/ColinDuquesnoy/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="examples test doc"
-
-RDEPEND=">=dev-python/helpdev-0.6.2[${PYTHON_USEDEP}]
- doc? ( dev-python/m2r[${PYTHON_USEDEP}] )
- examples? ( >=dev-python/QtPy-1.7[${PYTHON_USEDEP}] )"
-
-DEPEND="test? ( dev-python/QtPy[${PYTHON_USEDEP}] )"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_install_all() {
- if use examples; then
- insinto /usr/share/${PN}
- doins -r example
- fi
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- optfeature "qdarkstyle.utils" dev-python/qtsass
-}
diff --git a/dev-python/qdarkstyle/qdarkstyle-2.8.1.ebuild b/dev-python/qdarkstyle/qdarkstyle-2.8.1.ebuild
new file mode 100644
index 000000000000..6e23dfa14a68
--- /dev/null
+++ b/dev-python/qdarkstyle/qdarkstyle-2.8.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit eutils distutils-r1
+
+MY_PN="QDarkStyleSheet"
+
+DESCRIPTION="A dark style sheet for QtWidgets application"
+HOMEPAGE="https://github.com/ColinDuquesnoy/QDarkStyleSheet"
+SRC_URI="https://github.com/ColinDuquesnoy/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="examples"
+
+RDEPEND=">=dev-python/helpdev-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-1.7[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/qtsass[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme dev-python/m2r
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_prepare_all() {
+ #/var/tmp/portage/dev-python/qdarkstyle-2.8/temp/environment: line 2949: 66 Aborted (core dumped) pytest -vv
+ sed -i -e 's:test_create_custom_qss:_&:' \
+ test/test_sass_compiler.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # tests look for a file in source dir that is not installed
+ PYTHONPATH="${S}"
+ cd "${S}"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && dodoc -r example
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "qdarkstyle.utils" dev-python/qtsass
+}