summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2018-04-15 19:16:04 +0200
committerDavide Pesavento <pesa@gentoo.org>2018-04-15 19:16:23 +0200
commit864f33e4e2508aac5755cec83f77cc92702b952e (patch)
tree9987ef19f3c4c572ae8d898ae2739090cd11c212 /dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild
parentx11-libs/qscintilla: version bump (diff)
downloadgentoo-864f33e4e2508aac5755cec83f77cc92702b952e.tar.gz
gentoo-864f33e4e2508aac5755cec83f77cc92702b952e.tar.bz2
gentoo-864f33e4e2508aac5755cec83f77cc92702b952e.zip
dev-python/qscintilla-python: version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild')
-rw-r--r--dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild
new file mode 100644
index 000000000000..ab5f9388efba
--- /dev/null
+++ b/dev-python/qscintilla-python/qscintilla-python-2.10.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit python-r1 qmake-utils
+
+MY_P=QScintilla_gpl-${PV/_pre/.dev}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="https://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="debug"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,printsupport,widgets,${PYTHON_USEDEP}]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ ~x11-libs/qscintilla-${PV}:=
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_configure() {
+ configuration() {
+ # Fix out-of-source build and installation of .sip files
+ ln -s "${S}"/sip || die
+
+ local myconf=(
+ "${PYTHON}"
+ "${S}"/configure.py
+ --pyqt=PyQt5
+ --qmake="$(qt5_get_bindir)"/qmake
+ --sip-incdir="$(python_get_includedir)"
+ $(usex debug '--debug --trace' '')
+ --verbose
+ )
+ echo "${myconf[@]}"
+ "${myconf[@]}" || die
+
+ # Run eqmake to respect toolchain, build flags, and prevent stripping
+ eqmake5 -recursive
+ }
+ python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ installation() {
+ emake INSTALL_ROOT="${D}" install
+ python_optimize
+ }
+ python_foreach_impl run_in_build_dir installation
+}