summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-30 07:37:29 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-30 07:45:41 +0200
commit768db639168126ada8e791262cec18e35a6d66ae (patch)
tree72a4d98d39fd025bb846babe2ba8e4421cde2804 /dev-python/qtconsole
parentdev-python/python-debian: Bump to 0.1.47 (diff)
downloadgentoo-768db639168126ada8e791262cec18e35a6d66ae.tar.gz
gentoo-768db639168126ada8e791262cec18e35a6d66ae.tar.bz2
gentoo-768db639168126ada8e791262cec18e35a6d66ae.zip
dev-python/qtconsole: Bump to 5.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest1
-rw-r--r--dev-python/qtconsole/qtconsole-5.3.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index 8068dabd40ce..549a0cd39cae 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1 +1,2 @@
DIST qtconsole-5.3.1.tar.gz 430680 BLAKE2B 4655d9aa78a95200fb3f4d2016749d4f1c75865d259da8583818259d05301469b9851b85a2716336084f022f546e97ae003483284f0305793da80a5de7635ac2 SHA512 bebf9c97ebe2a030feebd34f9dbc83294af5eb64946b252c5b5e6391e2760ff95efa7f0be89ec59c424de5fefb3f876ead897d17b679fc87896fe440ba936554
+DIST qtconsole-5.3.2.tar.gz 430792 BLAKE2B 246dadaab92851f8da65dfa4c7e80390defeb0855fdb3ea5ef6aab96bf56b28597dc65d7cb4fc95f0f795a19f4b826d0ec1e1e0b025f4fa49d4d5a78473a2b29 SHA512 715e7e4b185a656f395a30c575e8996271cea4672871d9471c74a13364be1ef0fe0e63951e8f52f10b9c887592dc899c399ae82e09f9934492d13119b1154796
diff --git a/dev-python/qtconsole/qtconsole-5.3.2.ebuild b/dev-python/qtconsole/qtconsole-5.3.2.ebuild
new file mode 100644
index 000000000000..e065753cbc2d
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-5.3.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/qtconsole/
+ https://pypi.org/project/qtconsole/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/ipykernel-4.1[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-17.1[${PYTHON_USEDEP}]
+ >=dev-python/traitlets-5.2.2_p1[${PYTHON_USEDEP}]
+ >=dev-python/QtPy-2.0.1[${PYTHON_USEDEP},gui,printsupport,svg]
+"
+# The test suite tests both against pyqt5 *and* pyside2
+BDEPEND="
+ test? (
+ dev-python/QtPy[pyqt5,pyside2,${PYTHON_USEDEP},svg,testlib]
+ )
+"
+# required by the tests that are removed:
+# dev-python/flaky[${PYTHON_USEDEP}]
+# dev-python/pytest-qt[${PYTHON_USEDEP}]
+
+PDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+python_test() {
+ # TODO: these tests require virtx; however, running under virtx
+ # causes pytest to segv on exit (even though tests pass)
+ EPYTEST_IGNORE=(
+ qtconsole/tests/test_00_console_widget.py
+ qtconsole/tests/test_jupyter_widget.py
+ )
+ epytest
+}