summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-17 22:52:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-17 22:52:03 +0100
commit3b7aeba20698dfe1bdbb4ecfc97249ab13ddb79c (patch)
treec6ba0833780bd4ee2ca483eb28fc427308534d23 /dev-python/quantities
parentdev-python/debtcollector: Remove old (diff)
downloadgentoo-3b7aeba20698dfe1bdbb4ecfc97249ab13ddb79c.tar.gz
gentoo-3b7aeba20698dfe1bdbb4ecfc97249ab13ddb79c.tar.bz2
gentoo-3b7aeba20698dfe1bdbb4ecfc97249ab13ddb79c.zip
dev-python/quantities: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quantities')
-rw-r--r--dev-python/quantities/Manifest1
-rw-r--r--dev-python/quantities/files/quantities-0.12.5-numpy-1.21.patch29
-rw-r--r--dev-python/quantities/quantities-0.12.5.ebuild36
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/quantities/Manifest b/dev-python/quantities/Manifest
index e4e1eb9c9b3c..0495c7ec9fe7 100644
--- a/dev-python/quantities/Manifest
+++ b/dev-python/quantities/Manifest
@@ -1,2 +1 @@
-DIST python-quantities-0.12.5.tar.gz 105130 BLAKE2B db1cf09fa2efc249bc722abe34ed71d0f59d85595f70baf44203785c32179a3598be8aac225adadfd7d5f09c44ec077dcef310ee2fe7ce4d49a1533b04cb9de6 SHA512 db81e45d464e65d6b144d05e1b990fccc5c17ab7fdd47c7bb0c0094ebcacd6af52a3692492561af3a694741810ddac03e4c887d7c6effed833f196493da5f156
DIST python-quantities-0.13.0.tar.gz 107187 BLAKE2B ead5c223892f65c68ced2265356f8c1e5374f80a1507ec561370e56e28e8965217a7b99f5c46cb83a5f6a1b1f12eb9f501844650488871d48794f13a4383df38 SHA512 ec0a61d8df8e48e7ee08cab5c899a8c8ad96b964ee0132ab130f272f062436d91e6370aac9d85453eeb3d95e17e79e8dfb80412397eada1f0a4310c0494fa217
diff --git a/dev-python/quantities/files/quantities-0.12.5-numpy-1.21.patch b/dev-python/quantities/files/quantities-0.12.5-numpy-1.21.patch
deleted file mode 100644
index 34dd5a075412..000000000000
--- a/dev-python/quantities/files/quantities-0.12.5-numpy-1.21.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From f32e0ce2feeb588eb8b7236700c8c1176e2bc499 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Tue, 17 Aug 2021 08:24:07 +0200
-Subject: [PATCH] fix expected np.arctan2() exception for numpy 1.21
-
-NumPy 1.21 has changed the exception type for incorrect np.arctan2()
-arguments from ValueError to TypeError. Adjust the test appropriately.
-
-Fixes #190
----
- quantities/tests/test_umath.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/quantities/tests/test_umath.py b/quantities/tests/test_umath.py
-index f5aeb78..a7ebb18 100644
---- a/quantities/tests/test_umath.py
-+++ b/quantities/tests/test_umath.py
-@@ -226,7 +226,7 @@ class TestUmath(TestCase):
- np.arctan2(3*pq.V, 3*pq.V),
- np.radians(45)*pq.dimensionless
- )
-- self.assertRaises(ValueError, np.arctan2, (1*pq.m, 1*pq.m))
-+ self.assertRaises((TypeError, ValueError), np.arctan2, (1*pq.m, 1*pq.m))
-
- def test_hypot(self):
- self.assertQuantityEqual(np.hypot(3 * pq.m, 4 * pq.m), 5 * pq.m)
---
-2.32.0
-
diff --git a/dev-python/quantities/quantities-0.12.5.ebuild b/dev-python/quantities/quantities-0.12.5.ebuild
deleted file mode 100644
index 2697e7840c36..000000000000
--- a/dev-python/quantities/quantities-0.12.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=no
-
-inherit distutils-r1
-
-MY_P="python-quantities-${PV}"
-DESCRIPTION="Support for physical quantities with units, based on numpy"
-HOMEPAGE="https://github.com/python-quantities/python-quantities"
-SRC_URI="
- https://github.com/python-quantities/python-quantities/archive/v${PV}.tar.gz
- -> ${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="
- dev-python/numpy[$PYTHON_USEDEP]
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-numpy-1.21.patch
-)
-
-EPYTEST_DESELECT=(
- # unexpected success
- quantities/tests/test_umath.py::TestUmath::test_fix
-)