summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-05 20:02:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-05 20:10:27 +0200
commit525f1044c040a425021e135469e625e19c23005f (patch)
treed775adafba135d334aac1e8fa5a370c29e911116 /dev-python/quantities
parentdev-python/qrcode: Enable py3.10 (diff)
downloadgentoo-525f1044c040a425021e135469e625e19c23005f.tar.gz
gentoo-525f1044c040a425021e135469e625e19c23005f.tar.bz2
gentoo-525f1044c040a425021e135469e625e19c23005f.zip
dev-python/quantities: Enable py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/quantities')
-rw-r--r--dev-python/quantities/quantities-0.12.4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/quantities/quantities-0.12.4.ebuild b/dev-python/quantities/quantities-0.12.4.ebuild
index 337fd8fdd1ba..6a7c1364b3f6 100644
--- a/dev-python/quantities/quantities-0.12.4.ebuild
+++ b/dev-python/quantities/quantities-0.12.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,7 +7,7 @@ MY_PN="python-quantities"
MY_PV="$(ver_cut 1-3)"
MY_P="${MY_PN}-${PV}"
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
@@ -15,6 +15,7 @@ inherit distutils-r1
DESCRIPTION="Support for physical quantities with units, based on numpy"
HOMEPAGE="https://github.com/python-quantities/python-quantities"
SRC_URI="https://github.com/python-quantities/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${MY_PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
@@ -23,9 +24,8 @@ KEYWORDS="amd64 x86"
RDEPEND="
dev-python/numpy[$PYTHON_USEDEP]
"
-distutils_enable_tests unittest
-S="${WORKDIR}/${MY_P}"
+distutils_enable_tests unittest
python_prepare_all() {
# Unexpected success