summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-08-10 11:46:35 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-08-10 11:46:35 +0200
commitcb8dc18680f64045986e4fd4436653a5d6aacba6 (patch)
treed97610541272a5d1e6343a6ff803cb27f134990a /dev-python/quex
parentnet-libs/libnsl: arm stable wrt bug #736553 (diff)
downloadgentoo-cb8dc18680f64045986e4fd4436653a5d6aacba6.tar.gz
gentoo-cb8dc18680f64045986e4fd4436653a5d6aacba6.tar.bz2
gentoo-cb8dc18680f64045986e4fd4436653a5d6aacba6.zip
dev-python/quex: version bump to 0.70.0
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python/quex')
-rw-r--r--dev-python/quex/Manifest1
-rw-r--r--dev-python/quex/files/quex-0.70.0-gentoo.patch11
-rw-r--r--dev-python/quex/quex-0.70.0.ebuild50
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/quex/Manifest b/dev-python/quex/Manifest
index 28b6c4074ede..f082def745cb 100644
--- a/dev-python/quex/Manifest
+++ b/dev-python/quex/Manifest
@@ -1 +1,2 @@
DIST quex-0.65.4.tar.gz 2202154 BLAKE2B 6b273998c9641aeee458291245a4fb956b5fe9b66d8c42f0c1d9b360a4d171c830a1d487bcbab9ccea49d10b7532ed488ce66dc165f31cce9521f97c5a4575f4 SHA512 0b11d7e5c5165674626fbbe7f54853656c579c63b78bd2fef2f5a9b316171dc647812d9a37df4e7c49c05de11a307b6425089f4ab281affb6c03a9cf09e2a035
+DIST quex-0.70.0.7z 2002636 BLAKE2B 16082ed6fc96e63917bcd221fc0902194900a55dcf4778661c159f1fc89282d8e5b7bc0125ebf90419bfd7c671be87cf485e6db29b8159d9f382e61996a9a16e SHA512 8c1687e33c31b3f0910e74146dcd0a0413250357240c1ee28d0df6d7fca918d4577dbab4f78cecdd82133475226e795a66fbcdccedf086aaf88cd225bfbbd935
diff --git a/dev-python/quex/files/quex-0.70.0-gentoo.patch b/dev-python/quex/files/quex-0.70.0-gentoo.patch
new file mode 100644
index 000000000000..c110c4bdb24d
--- /dev/null
+++ b/dev-python/quex/files/quex-0.70.0-gentoo.patch
@@ -0,0 +1,11 @@
+--- a/quex/DEFINITIONS.py 2017-12-13 21:48:52.887765325 +0100
++++ b/quex/DEFINITIONS.py 2017-12-13 21:52:29.805877359 +0100
+@@ -57,7 +57,7 @@
+ global QUEX_INSTALLATION_DIR
+
+ # -- Try to acces the file 'quex-exe.py' in order to verify
+- if os.access(QUEX_INSTALLATION_DIR + "/quex-exe.py", os.F_OK) == False:
++ if False:
+ print "error: Environment variable 'QUEX_PATH' does not point to"
+ print "error: a valid installation directory of quex."
+ print "error: current setting of 'QUEX_PATH':"
diff --git a/dev-python/quex/quex-0.70.0.ebuild b/dev-python/quex/quex-0.70.0.ebuild
new file mode 100644
index 000000000000..5237166e0f57
--- /dev/null
+++ b/dev-python/quex/quex-0.70.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Mode Oriented Directly Coded Lexical Analyser Generator"
+HOMEPAGE="http://quex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.7z"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+BDEPEND="${RDEPEND}"
+DEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:@PYTHON_SITEDIR@:$(python_get_sitedir):g" \
+ quex/DEFINITIONS.py || die
+ mkdir -p engine/codec_db/unicode || die
+ mv quex/engine/codec_db/database engine/codec_db/ || die
+ mv quex/engine/codec_db/unicode/database engine/codec_db/unicode/ || die
+ mv quex/code_base . || die
+}
+
+src_install() {
+ default
+ insinto /usr/share/quex/
+ doins -r engine
+ doins -r code_base
+
+ python_domodule quex
+ python_newscript quex-exe.py quex
+ doman manpage/quex.1
+ dodoc -r demo
+ insinto /etc/profile.d/
+ doins "${FILESDIR}"/quex.sh
+}