summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 14:51:32 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 15:09:52 -0700
commitbe650f15222db24b5a5c1eca3a45fe36bcc58a64 (patch)
treeaa7a733ba367e1bfbb7b45e53d2d66c0213cafb8 /dev-python/raet/raet-0.6.8-r1.ebuild
parentdev-python/awscli: bump to v1.18.48 (diff)
downloadgentoo-be650f15222db24b5a5c1eca3a45fe36bcc58a64.tar.gz
gentoo-be650f15222db24b5a5c1eca3a45fe36bcc58a64.tar.bz2
gentoo-be650f15222db24b5a5c1eca3a45fe36bcc58a64.zip
dev-python/raet-0.6.8-r1: revbump, py37, py38, drop py36 due to ioflo
Closes: https://bugs.gentoo.org/719508 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/raet/raet-0.6.8-r1.ebuild')
-rw-r--r--dev-python/raet/raet-0.6.8-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/raet/raet-0.6.8-r1.ebuild b/dev-python/raet/raet-0.6.8-r1.ebuild
new file mode 100644
index 000000000000..fefe499a48f7
--- /dev/null
+++ b/dev-python/raet/raet-0.6.8-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7,8})
+inherit distutils-r1
+
+DESCRIPTION="Reliable Asynchronous Event Transport Protocol"
+HOMEPAGE="https://github.com/RaetProtocol/raet"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/libnacl-1.4.3[${PYTHON_USEDEP}]
+ >=dev-python/ioflo-2.0[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=(
+ # This is from https://github.com/RaetProtocol/raet/pull/14/
+ #${FILESDIR}/raet-0.6.8-msgpack-1.0.patch
+)
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ sed -i -e "/setuptools_git/d" setup.py || die
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib || die
+ ${EPYTHON} ${PN}/test/__init__.py || die "tests failed for ${EPYTHON}"
+ popd || die
+}