summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-26 17:24:20 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-26 17:26:32 +0200
commita6a312d0d4ab2343c26c9c3ee0941b47d6a6c314 (patch)
treed0e6b696683a4b33351d9af1d8e1983ce3f92f0d /dev-python/ramlfications/ramlfications-0.1.9.ebuild
parentdev-python/markdown2: Tested on py3.5 & py3.6 (diff)
downloadgentoo-a6a312d0d4ab2343c26c9c3ee0941b47d6a6c314.tar.gz
gentoo-a6a312d0d4ab2343c26c9c3ee0941b47d6a6c314.tar.bz2
gentoo-a6a312d0d4ab2343c26c9c3ee0941b47d6a6c314.zip
dev-python/ramlfications: Add missing test dep, enable tests
There are 2 test failures. One looks like an undefined missing dep, the other is completely unclear.
Diffstat (limited to 'dev-python/ramlfications/ramlfications-0.1.9.ebuild')
-rw-r--r--dev-python/ramlfications/ramlfications-0.1.9.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-python/ramlfications/ramlfications-0.1.9.ebuild b/dev-python/ramlfications/ramlfications-0.1.9.ebuild
index b3d33336c024..229e61c21744 100644
--- a/dev-python/ramlfications/ramlfications-0.1.9.ebuild
+++ b/dev-python/ramlfications/ramlfications-0.1.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,5 +30,10 @@ DEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
)
"
+
+python_test() {
+ esetup.py test
+}