summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2016-12-31 09:38:12 +0000
committerIan Whyman <thev00d00@gentoo.org>2016-12-31 09:38:12 +0000
commit1f787782eb37f8199419d725c21086346e7d0b6b (patch)
tree45e4aa132e2919130c465febdbb050c333b65940 /dev-python/rarfile/rarfile-3.0.ebuild
parentnet-libs/xrootd: x86 stable wrt bug #601870 (diff)
downloadgentoo-1f787782eb37f8199419d725c21086346e7d0b6b.tar.gz
gentoo-1f787782eb37f8199419d725c21086346e7d0b6b.tar.bz2
gentoo-1f787782eb37f8199419d725c21086346e7d0b6b.zip
dev-python/rarfile: Version bump
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/rarfile/rarfile-3.0.ebuild')
-rw-r--r--dev-python/rarfile/rarfile-3.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/rarfile/rarfile-3.0.ebuild b/dev-python/rarfile/rarfile-3.0.ebuild
new file mode 100644
index 000000000000..3627f568ca8a
--- /dev/null
+++ b/dev-python/rarfile/rarfile-3.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="https://github.com/markokr/rarfile"
+SRC_URI="mirror://pypi/r/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compressed"
+
+RDEPEND="${DEPEND}
+ compressed? ( || ( app-arch/unrar app-arch/rar ) )"