summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 02:14:47 +0100
committerSam James <sam@gentoo.org>2022-06-01 02:25:14 +0100
commit0a18d08236f7980cd5207392c733c46a1f1282e2 (patch)
tree7a8d063bfc83be07b1f5262946ed9fb7f3803ee6 /dev-python/rarfile
parentdev-python/dogpile-cache: enable py3.11 (diff)
downloadgentoo-0a18d08236f7980cd5207392c733c46a1f1282e2.tar.gz
gentoo-0a18d08236f7980cd5207392c733c46a1f1282e2.tar.bz2
gentoo-0a18d08236f7980cd5207392c733c46a1f1282e2.zip
dev-python/rarfile: update EAPI 7 -> 8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/rarfile')
-rw-r--r--dev-python/rarfile/rarfile-4.0-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/rarfile/rarfile-4.0-r1.ebuild b/dev-python/rarfile/rarfile-4.0-r1.ebuild
new file mode 100644
index 000000000000..8c383b1620e6
--- /dev/null
+++ b/dev-python/rarfile/rarfile-4.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTLS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="https://github.com/markokr/rarfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+compressed test"
+REQUIRED_USE="test? ( compressed )"
+
+RDEPEND="compressed? ( app-arch/unrar )"
+
+PATCHES=( "${FILESDIR}"/${P}.patch )
+
+distutils_enable_tests pytest