summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-03-03 02:17:48 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-03-03 03:07:11 +0100
commit36c56216373ba92bf46c1b2be0f295342c05d5e9 (patch)
tree9eccffb77376bf0bd203801c5af59464900a32c2 /dev-python/raven/raven-5.33.0.ebuild
parentdev-python/libcloud: Bump to v1.5.0 (diff)
downloadgentoo-36c56216373ba92bf46c1b2be0f295342c05d5e9.tar.gz
gentoo-36c56216373ba92bf46c1b2be0f295342c05d5e9.tar.bz2
gentoo-36c56216373ba92bf46c1b2be0f295342c05d5e9.zip
dev-python/raven: Bump to v5.33.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/raven/raven-5.33.0.ebuild')
-rw-r--r--dev-python/raven/raven-5.33.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/raven/raven-5.33.0.ebuild b/dev-python/raven/raven-5.33.0.ebuild
new file mode 100644
index 000000000000..c7e0984444d2
--- /dev/null
+++ b/dev-python/raven/raven-5.33.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Raven is a client for Sentry"
+HOMEPAGE="https://github.com/getsentry/raven-python"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/contextlib2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"