summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rax-scheduled-images-python-novaclient-ext
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rax-scheduled-images-python-novaclient-ext')
-rw-r--r--dev-python/rax-scheduled-images-python-novaclient-ext/Manifest1
-rw-r--r--dev-python/rax-scheduled-images-python-novaclient-ext/metadata.xml16
-rw-r--r--dev-python/rax-scheduled-images-python-novaclient-ext/rax-scheduled-images-python-novaclient-ext-0.2.1.ebuild21
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/rax-scheduled-images-python-novaclient-ext/Manifest b/dev-python/rax-scheduled-images-python-novaclient-ext/Manifest
new file mode 100644
index 000000000000..b457ee5fc4c6
--- /dev/null
+++ b/dev-python/rax-scheduled-images-python-novaclient-ext/Manifest
@@ -0,0 +1 @@
+DIST rax_scheduled_images_python_novaclient_ext-0.2.1.tar.gz 2781 SHA256 17236eb56c7216472d66652579531f0725fe14ee72e8b35a86fc7ca3aa734f01 SHA512 d26fcb8c4cc70b7e4b31f4eb8306d094139d914fbdaf9fda846f13a2bb6336734b2aebc4c7322df5986ba1cc57d4d5894e744ded063f4a01d7a63d3642049672 WHIRLPOOL 4e0cf12f03b08e5a06aeeeef5026e3bf0695f5ed23a229a0507d51c27de7d3cffea14256af3758a1d2070e17593ffb5353071be21e5bc27654c22a2ed888aa16
diff --git a/dev-python/rax-scheduled-images-python-novaclient-ext/metadata.xml b/dev-python/rax-scheduled-images-python-novaclient-ext/metadata.xml
new file mode 100644
index 000000000000..7f7c40453920
--- /dev/null
+++ b/dev-python/rax-scheduled-images-python-novaclient-ext/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Adds backup-schedule extension support to python-novaclient.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rax_scheduled_images_python_novaclient_ext</remote-id>
+ <remote-id type="github">rackspace/rax_backup_schedule_python_novaclient_ext</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rax-scheduled-images-python-novaclient-ext/rax-scheduled-images-python-novaclient-ext-0.2.1.ebuild b/dev-python/rax-scheduled-images-python-novaclient-ext/rax-scheduled-images-python-novaclient-ext-0.2.1.ebuild
new file mode 100644
index 000000000000..ea92e468c09c
--- /dev/null
+++ b/dev-python/rax-scheduled-images-python-novaclient-ext/rax-scheduled-images-python-novaclient-ext-0.2.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds backup-schedule extension support to python-novaclient"
+HOMEPAGE="https://github.com/rackspace/rax_backup_schedule_python_novaclient_ext"
+SRC_URI="mirror://pypi/${PN:0:1}/rax_scheduled_images_python_novaclient_ext/rax_scheduled_images_python_novaclient_ext-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/rax_scheduled_images_python_novaclient_ext-${PV}"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=">=dev-python/python-novaclient-2.10.0[${PYTHON_USEDEP}]"