summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rdflib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rdflib')
-rw-r--r--dev-python/rdflib/Manifest3
-rw-r--r--dev-python/rdflib/files/rdflib-3.1.0-test.patch20
-rw-r--r--dev-python/rdflib/metadata.xml12
-rw-r--r--dev-python/rdflib/rdflib-3.2.3-r1.ebuild47
-rw-r--r--dev-python/rdflib/rdflib-4.1.2.ebuild62
-rw-r--r--dev-python/rdflib/rdflib-4.2.0.ebuild62
6 files changed, 206 insertions, 0 deletions
diff --git a/dev-python/rdflib/Manifest b/dev-python/rdflib/Manifest
new file mode 100644
index 000000000000..8f4d6b4e192b
--- /dev/null
+++ b/dev-python/rdflib/Manifest
@@ -0,0 +1,3 @@
+DIST rdflib-3.2.3.tar.gz 449077 SHA256 a3cab51c14fa6fe379261e0157c110d94e2f75ef62073ddc76fe56f5be624b75 SHA512 92697be6d6bba4e31303b46c2a42defd840770f75c6f359b7338fa3d48a2001cdcda3b6319403ad0c9f1696051d773b146c9b012770df81b4d94a34d30f6b02a WHIRLPOOL b41794febee280022990dac8c4e177660f69803f01fc14ade194015bc6cf1eaf23164620b09cf1123445d181c0bbe9f0733b901cddafb126bcd711d0462a9f7b
+DIST rdflib-4.1.2.tar.gz 868883 SHA256 3cf94bda0867f21468b248ce9f671581efb92ae9edd28ff321716126c6706a4f SHA512 99d4a4b4d37808563575ac13312cf0e0975f7c1563117cfe7e4b70a84a2804f7eb57144d6a7c629c109ff7b236a6ea2489a4925ae41791274f3b234143837e65 WHIRLPOOL 090e00cc3113cec158f786a39103450f0d1d25571ad57c346120756901f01b0fcf20ff731ae3b174b54f3621e46a26061eee7bd774ffdf91380f4a3647380590
+DIST rdflib-4.2.0.tar.gz 881424 SHA256 7420dafc4930249d0cfcf31e8547a39b658d079ab2c9e975465f6697a8476ec0 SHA512 7677869eb0a65ede317634253042da68b4e183d5352cd37bd949380eb29deec8329336067a2ab686c90d6a1718f8e7a9039424753846d879cce41c05f656735f WHIRLPOOL 62f67318ade0fee1d5d64d6294aa821f4f06f940b18e421d43292e749e495cb3e348b522dd79eec805ce88125d8a6864dccc4a4037ed0a52d5aed616e51b39f5
diff --git a/dev-python/rdflib/files/rdflib-3.1.0-test.patch b/dev-python/rdflib/files/rdflib-3.1.0-test.patch
new file mode 100644
index 000000000000..aea1bf5ac723
--- /dev/null
+++ b/dev-python/rdflib/files/rdflib-3.1.0-test.patch
@@ -0,0 +1,20 @@
+ rdflib/__init__.py | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/rdflib/__init__.py b/rdflib/__init__.py
+index b781031..44efb0b 100644
+--- a/rdflib/__init__.py
++++ b/rdflib/__init__.py
+@@ -15,10 +15,10 @@ A tiny example:
+ >>> import rdflib
+
+ >>> g = rdflib.Graph()
+- >>> result = g.parse("http://eikeon.com/foaf.rdf")
++ >>> result = g.parse("http://www.w3.org/2000/10/swap/test/meet/white.rdf")
+
+ >>> print "graph has %s statements." % len(g)
+- graph has 34 statements.
++ graph has 19 statements.
+ >>>
+ >>> for s, p, o in g:
+ ... if (s, p, o) not in g:
diff --git a/dev-python/rdflib/metadata.xml b/dev-python/rdflib/metadata.xml
new file mode 100644
index 000000000000..53fc3d1ed97e
--- /dev/null
+++ b/dev-python/rdflib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <use>
+ <flag name="redland">enable support for Redland triplestore</flag>
+ </use>
+ <upstream>
+ <remote-id type="pypi">rdflib</remote-id>
+ <remote-id type="github">RDFLib/rdflib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rdflib/rdflib-3.2.3-r1.ebuild b/dev-python/rdflib/rdflib-3.2.3-r1.ebuild
new file mode 100644
index 000000000000..22f484a537b0
--- /dev/null
+++ b/dev-python/rdflib/rdflib-3.2.3-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+PYTHON_REQ_USE="sqlite?"
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3 )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
+ redland? ( dev-libs/redland-bindings[python] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests --verbosity=3 --py3where='build/src' || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}
diff --git a/dev-python/rdflib/rdflib-4.1.2.ebuild b/dev-python/rdflib/rdflib-4.1.2.ebuild
new file mode 100644
index 000000000000..da5d38550c97
--- /dev/null
+++ b/dev-python/rdflib/rdflib-4.1.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite?"
+DISTUTILS_NO_PARALLEL_BUILD=true
+# The usual required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[$(python_gen_usedep 'python2*')]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
+ redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep 'python2*')] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if python_is_python3; then
+ pushd "${BUILD_DIR}/src/" > /dev/null
+ if [[ "${EPYTHON}" == 'python3.4' ]]; then
+ sed -e 's:test_rdfpipe_bytes_vs_str:_&:' \
+ -e 's:test_rdfpipe_mdata_open:_&:' \
+ -i test/test_issue375.py || die
+ sed -e 's:testHTML:_&:' \
+ -i test/test_xmlliterals.py || die
+ fi
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+ else
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/rdflib/rdflib-4.2.0.ebuild b/dev-python/rdflib/rdflib-4.2.0.ebuild
new file mode 100644
index 000000000000..9ab19201e212
--- /dev/null
+++ b/dev-python/rdflib/rdflib-4.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite?"
+DISTUTILS_NO_PARALLEL_BUILD=true
+# The usual required for tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+inherit distutils-r1
+
+DESCRIPTION="RDF library containing a triple store and parser/serializer"
+HOMEPAGE="https://github.com/RDFLib/rdflib http://pypi.python.org/pypi/rdflib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="berkdb examples mysql redland sqlite test"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ dev-python/html5lib[$(python_gen_usedep 'python2*')]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ berkdb? ( dev-python/bsddb3[${PYTHON_USEDEP}] )
+ mysql? ( dev-python/mysql-python[$(python_gen_usedep 'python2*')] )
+ redland? ( dev-libs/redland-bindings[python,$(python_gen_usedep 'python2*')] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/sparql-wrapper[${PYTHON_USEDEP}]
+ >=dev-python/nose-1.3.1-r1[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Upstream manufactured .pyc files which promptly break distutils' src_test
+ find -name "*.py[oc~]" -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if python_is_python3; then
+ pushd "${BUILD_DIR}/src/" > /dev/null
+ if [[ "${EPYTHON}" == 'python3.4' ]]; then
+ sed -e 's:test_rdfpipe_bytes_vs_str:_&:' \
+ -e 's:test_rdfpipe_mdata_open:_&:' \
+ -i test/test_issue375.py || die
+ sed -e 's:testHTML:_&:' \
+ -i test/test_xmlliterals.py || die
+ fi
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ popd > /dev/null
+ else
+ "${PYTHON}" ./run_tests.py || die "Tests failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}