summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-16 10:16:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-16 10:16:11 +0100
commit0930e45ee0dd9caf9c66a47e3b9fdc1890520224 (patch)
tree9038b25c313080bf947dbfdf0a5dbbad91c76254 /dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.5.ebuild
parentdev-python/regex: Bump to 2022.3.15 (diff)
downloadgentoo-0930e45ee0dd9caf9c66a47e3b9fdc1890520224.tar.gz
gentoo-0930e45ee0dd9caf9c66a47e3b9fdc1890520224.tar.bz2
gentoo-0930e45ee0dd9caf9c66a47e3b9fdc1890520224.zip
dev-python/readthedocs-sphinx-ext: Bump to 2.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.5.ebuild')
-rw-r--r--dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.5.ebuild b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.5.ebuild
new file mode 100644
index 000000000000..b4253afe415e
--- /dev/null
+++ b/dev-python/readthedocs-sphinx-ext/readthedocs-sphinx-ext-2.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Code specific for Read the Docs and Sphinx"
+HOMEPAGE="https://github.com/readthedocs/readthedocs-sphinx-ext"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/jinja-2.9[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+PDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( ${PDEPEND} )
+"
+
+# unittest should be sufficient but tests are very verbose, so pytest's
+# output capture is most welcome
+distutils_enable_tests pytest