summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-01 23:44:00 +0100
committerSam James <sam@gentoo.org>2022-06-02 01:09:43 +0100
commitb1c114d5e8dd4ae1572ddaa60c0256ebd3dea442 (patch)
tree2e5cbafc4249a0feaae1cd5a7383c1aa0e080061 /dev-python/redis-py
parentx11-misc/cbatticon: add 1.6.13 (diff)
downloadgentoo-b1c114d5e8dd4ae1572ddaa60c0256ebd3dea442.tar.gz
gentoo-b1c114d5e8dd4ae1572ddaa60c0256ebd3dea442.tar.bz2
gentoo-b1c114d5e8dd4ae1572ddaa60c0256ebd3dea442.zip
dev-python/redis-py: add 4.3.2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/redis-py')
-rw-r--r--dev-python/redis-py/Manifest1
-rw-r--r--dev-python/redis-py/redis-py-4.3.2.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/redis-py/Manifest b/dev-python/redis-py/Manifest
index d3bf1fbb3f1e..e4e17c046479 100644
--- a/dev-python/redis-py/Manifest
+++ b/dev-python/redis-py/Manifest
@@ -2,3 +2,4 @@ DIST redis-py-4.1.4.tar.gz 2352106 BLAKE2B a7f40d381e3e1d295d2ce88f0adb897704d00
DIST redis-py-4.2.2.tar.gz 2421362 BLAKE2B ab59a649e8bc08d706536f994f0462505cea39828072884739b1a6434b45fd120e3b8acb51e8e88ec9fe0ce9acc0bfd6a5ff92bb67080724c7b121ef539af16f SHA512 80673d48cd97af1c5ebc67e919f16891ccb20cd30bc06619ddffeb117ad87f82b73f9b9bda6d36829bc51a35aa3c9b2af7c879ec665cc9664bdd86ac6510095b
DIST redis-py-4.3.0.gh.tar.gz 4605505 BLAKE2B a7cdf8941f99291f6c6f53e6b11b1cd45fd64d0d96e11848d648964518a970275152c00c3aec3a0342ffc5a4805624344076154d007684ce90137f37df4d90f7 SHA512 881f250f04cd0376d2e617ff07cba3c4f987574d64b0813890310412293c7825bb11a5117b65b27dad05bbdff250f44a736d542ee116034b7a644c6e58f981fd
DIST redis-py-4.3.1.gh.tar.gz 4605537 BLAKE2B 239dd9be0e6c30dbaeeb609f222802f33e4a4e4a743fe1f348f542fe899b89e47ad9513bf99db713d3cbcb13df0e6593d4631745c3afc3368f8a9e8333b759a8 SHA512 8d38876fbf3593825bf593188a9749bec0f652907f510657e32043ed26fd6d59b1554870f59af65939754500645e4c4c8f15bcb8eab1385a0640c374aa938643
+DIST redis-py-4.3.2.gh.tar.gz 4610682 BLAKE2B 1fe8a0aadfbc094fb0904cf2ed71a8d14245cf9f09638073f2fdc5713560cf66d5e00eaef7ab2ad9d68f00b838c5b762c95ca4589075db72b16cfaf5aa31477a SHA512 0d6458c4ecc676a1af6ec96648eecc30e872cbf5546701ee6b8b06feb0f30cab2bfd5de8700ea3e9628ec7cdc8e851460fa248963a745ac73cc0611c6a8787e5
diff --git a/dev-python/redis-py/redis-py-4.3.2.ebuild b/dev-python/redis-py/redis-py-4.3.2.ebuild
new file mode 100644
index 000000000000..2ff14c069707
--- /dev/null
+++ b/dev-python/redis-py/redis-py-4.3.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Redis key-value store"
+HOMEPAGE="
+ https://github.com/redis/redis-py/
+ https://pypi.org/project/redis/
+"
+SRC_URI="
+ https://github.com/redis/redis-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/async_timeout-4.0.2[${PYTHON_USEDEP}]
+ >=dev-python/deprecated-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ <dev-db/redis-7
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Flaky test
+ tests/test_pubsub.py::TestPubSubDeadlock::test_pubsub_deadlock
+ )
+
+ # TODO: try to run more servers?
+ epytest -m "not redismod and not onlycluster and not replica and not ssl"
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ # "${EPREFIX}"/usr/sbin/redis-server - <<< "${redis_test_config}" || die
+ "${EPREFIX}"/usr/sbin/redis-server - <<- EOF || die "Unable to start redis server"
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}