summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-12 17:27:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-12 17:44:38 +0200
commit795d80c01e67318904e18fc7dec3cf87e73e4c99 (patch)
treebd3357c7712dcf7416af376333aa5d1a38fa6bf4 /dev-python/referencing/referencing-0.29.0.ebuild
parentdev-python/rpds-py: New package, v0.7.1 (diff)
downloadgentoo-795d80c01e67318904e18fc7dec3cf87e73e4c99.tar.gz
gentoo-795d80c01e67318904e18fc7dec3cf87e73e4c99.tar.bz2
gentoo-795d80c01e67318904e18fc7dec3cf87e73e4c99.zip
dev-python/referencing: New package, v0.29.0
New dependency for dev-python/jsonschema-spec version bump. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/referencing/referencing-0.29.0.ebuild')
-rw-r--r--dev-python/referencing/referencing-0.29.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/referencing/referencing-0.29.0.ebuild b/dev-python/referencing/referencing-0.29.0.ebuild
new file mode 100644
index 000000000000..9350b4f52960
--- /dev/null
+++ b/dev-python/referencing/referencing-0.29.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+SUITE_COMMIT=f6fa54deec2ba3ae7326e6c292b2d7c4c20e9eb4
+SUITE_P=referencing-suite-${SUITE_COMMIT}
+
+DESCRIPTION="Cross-specification JSON referencing (JSON Schema, OpenAPI...)"
+HOMEPAGE="
+ https://github.com/python-jsonschema/referencing/
+ https://pypi.org/project/referencing/
+"
+SRC_URI+="
+ test? (
+ https://github.com/python-jsonschema/referencing-suite/archive/${SUITE_COMMIT}.tar.gz
+ -> ${SUITE_P}.gh.tar.gz
+ )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x REFERENCING_SUITE=${WORKDIR}/${SUITE_P}
+ epytest
+}