summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-14 20:46:35 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-14 20:46:35 +0100
commit0a1f5b9ae7f1bf372be703a7d53b9f2805f72be8 (patch)
treebdc1f30c44faf0b9d06dc0ce46c789640b28fa67 /dev-python/referencing/referencing-0.31.0.ebuild
parentnet-im/mattermost-desktop-bin: add 5.6.0_rc1 (diff)
downloadgentoo-0a1f5b9ae7f1bf372be703a7d53b9f2805f72be8.tar.gz
gentoo-0a1f5b9ae7f1bf372be703a7d53b9f2805f72be8.tar.bz2
gentoo-0a1f5b9ae7f1bf372be703a7d53b9f2805f72be8.zip
dev-python/referencing: Bump to 0.31.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/referencing/referencing-0.31.0.ebuild')
-rw-r--r--dev-python/referencing/referencing-0.31.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/referencing/referencing-0.31.0.ebuild b/dev-python/referencing/referencing-0.31.0.ebuild
new file mode 100644
index 000000000000..662ed455363c
--- /dev/null
+++ b/dev-python/referencing/referencing-0.31.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Cross-specification JSON referencing (JSON Schema, OpenAPI...)"
+HOMEPAGE="
+ https://github.com/python-jsonschema/referencing/
+ https://pypi.org/project/referencing/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/attrs-22.2.0[${PYTHON_USEDEP}]
+ >=dev-python/rpds-py-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-subtests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest