summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-04-07 02:44:50 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-04-07 02:44:50 +0200
commitcc3581c5279f08f1067df7edd537d0fa705337ad (patch)
tree807d1795c536c6c8911756da97a07811fd3ebc45 /dev-python/regex/regex-2017.04.05.ebuild
parentdev-python/jsonmerge: Version bump to 1.3.0 (diff)
downloadgentoo-cc3581c5279f08f1067df7edd537d0fa705337ad.tar.gz
gentoo-cc3581c5279f08f1067df7edd537d0fa705337ad.tar.bz2
gentoo-cc3581c5279f08f1067df7edd537d0fa705337ad.zip
dev-python/regex: Version bump to 2017.04.05
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/regex/regex-2017.04.05.ebuild')
-rw-r--r--dev-python/regex/regex-2017.04.05.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/regex/regex-2017.04.05.ebuild b/dev-python/regex/regex-2017.04.05.ebuild
new file mode 100644
index 000000000000..4057d9772b63
--- /dev/null
+++ b/dev-python/regex/regex-2017.04.05.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Alternative regular expression module to replace re"
+HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DOCS=( README docs/UnicodeProperties.txt )
+
+python_compile() {
+ if ! python_is_python3; then
+ local CFLAGS=${CFLAGS}
+ append-cflags -fno-strict-aliasing
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local msg="tests failed under ${EPYTHON}"
+ # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
+ einfo "There is one trivial fail of test test_empty_array under pypy"
+
+ if python_is_python3; then
+ "${PYTHON}" Python3/test_regex.py || die $msg
+ else
+ "${PYTHON}" Python2/test_regex.py || die $msg
+ fi
+}
+
+python_install_all() {
+ local DOCS="${DOCS} docs/UnicodeProperties.txt"
+ use doc && local HTML_DOCS=( docs/Features.html )
+
+ distutils-r1_python_install_all
+}