summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-04-08 19:50:43 +0200
committerSebastian Pipping <sping@gentoo.org>2020-04-08 19:50:43 +0200
commitc67afd3043446f8eed58ea3b7e1dbec6b956be24 (patch)
treebe0e067b5ab7142f4c6a22c2029af3e2792fdcf8 /dev-python/regex/regex-2020.4.4.ebuild
parentprofiles/arch: remove unmask of ada USE flag (diff)
downloadgentoo-c67afd3043446f8eed58ea3b7e1dbec6b956be24.tar.gz
gentoo-c67afd3043446f8eed58ea3b7e1dbec6b956be24.tar.bz2
gentoo-c67afd3043446f8eed58ea3b7e1dbec6b956be24.zip
dev-python/regex: 2020.4.4
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.96, Repoman-2.3.22
Diffstat (limited to 'dev-python/regex/regex-2020.4.4.ebuild')
-rw-r--r--dev-python/regex/regex-2020.4.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/regex/regex-2020.4.4.ebuild b/dev-python/regex/regex-2020.4.4.ebuild
new file mode 100644
index 000000000000..bb8200cfbc76
--- /dev/null
+++ b/dev-python/regex/regex-2020.4.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Alternative regular expression module to replace re"
+HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc"
+
+PATCHES=(
+ "${FILESDIR}/regex-2019.11.1-pypy.patch"
+)
+
+python_test() {
+ distutils_install_for_testing
+
+ pushd "${BUILD_DIR}/lib" > /dev/null || die
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/Features.html )
+ local DOCS=( README.rst docs/*.rst )
+
+ distutils-r1_python_install_all
+}