summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:17:12 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:26:44 +0300
commitb126f21888c66670ffce65cd1ff8286202a33f2b (patch)
tree3eff5b89390c58afa272c706be19b06a3af6ecd8 /dev-python/rencode
parentdev-python/restructuredtext-lint: enable py3.11 (diff)
downloadgentoo-b126f21888c66670ffce65cd1ff8286202a33f2b.tar.gz
gentoo-b126f21888c66670ffce65cd1ff8286202a33f2b.tar.bz2
gentoo-b126f21888c66670ffce65cd1ff8286202a33f2b.zip
dev-python/rencode: EAPI=8, USE pep517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rencode')
-rw-r--r--dev-python/rencode/rencode-1.0.6-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/rencode/rencode-1.0.6-r3.ebuild b/dev-python/rencode/rencode-1.0.6-r3.ebuild
new file mode 100644
index 000000000000..89539dbe3271
--- /dev/null
+++ b/dev-python/rencode/rencode-1.0.6-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="similar to bencode from the BitTorrent project"
+HOMEPAGE="https://github.com/aresch/rencode"
+SRC_URI="https://github.com/aresch/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ # https://github.com/aresch/rencode/commit/16e61e1ff4294bddb7c881536d3d454355c78969
+ "${FILESDIR}/${P}-drop-wheel-dependency.patch"
+ # bug #812437
+ "${FILESDIR}/${P}-fix-CVE-2021-40839.patch"
+)
+
+python_test() {
+ # The C extension ("_rencode") can't be imported from "${S}/rencode"
+ # so we need to cd somewhere else to make sure "rencode" is imported
+ # from ${BUILD_DIR}/lib (thanks to PYTHONPATH).
+ cd "${T}" || die
+ epytest "${S}"
+}