summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-01-28 18:28:22 -0800
committerPatrick McLean <chutzpah@gentoo.org>2020-01-29 11:53:08 -0800
commit06a54d7f4d312eb44ca519cb895643d8e5b7c712 (patch)
tree8e0bdca2c5bfad000f8f59c2ca0a3e59efe66eed /dev-python/reno/reno-2.11.3.ebuild
parentdev-python/wrapt-1.11.2-r1: Revbump, add py38, use new eclass funcs (diff)
downloadgentoo-06a54d7f4d312eb44ca519cb895643d8e5b7c712.tar.gz
gentoo-06a54d7f4d312eb44ca519cb895643d8e5b7c712.tar.bz2
gentoo-06a54d7f4d312eb44ca519cb895643d8e5b7c712.zip
dev-python/reno-2.11.3: Version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/reno/reno-2.11.3.ebuild')
-rw-r--r--dev-python/reno/reno-2.11.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/reno/reno-2.11.3.ebuild b/dev-python/reno/reno-2.11.3.ebuild
new file mode 100644
index 000000000000..d0f96e1bc5e2
--- /dev/null
+++ b/dev-python/reno/reno-2.11.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.org/project/reno/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
+RDEPEND="${BDEPEND}
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"