summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-07 23:33:05 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-07 23:36:48 +0200
commit07add58b59ee1d61214c3e7e5e4321a325b14782 (patch)
treef535682d0613478101eac40b970460d8494cbcf7 /dev-python/reno
parentdev-python/yarl: Bump to 1.7.0 (diff)
downloadgentoo-07add58b59ee1d61214c3e7e5e4321a325b14782.tar.gz
gentoo-07add58b59ee1d61214c3e7e5e4321a325b14782.tar.bz2
gentoo-07add58b59ee1d61214c3e7e5e4321a325b14782.zip
dev-python/reno: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reno')
-rw-r--r--dev-python/reno/Manifest1
-rw-r--r--dev-python/reno/reno-3.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/reno/Manifest b/dev-python/reno/Manifest
index 36a196a5f0e9..626eefb60a72 100644
--- a/dev-python/reno/Manifest
+++ b/dev-python/reno/Manifest
@@ -1 +1,2 @@
DIST reno-3.4.0.tar.gz 82815 BLAKE2B aab374c48c1dcf25ba7a78d46069c5d659762bf01d25dc05f597f02098ee10e7b8c518a0afad186ecd93602782a7c50294183b7e33075f8bfe57cc0bc3c1d016 SHA512 cbfd5d9b41beb1599438e249b8082175c8bd2b8dca62d8e6fd1ef742bf889adf6490e1ed0fa78d8aca663a0fb6bbe70742815a6512c6d51fb8073745b6860d65
+DIST reno-3.5.0.tar.gz 83644 BLAKE2B 803d3d3c9ed572624b77d2851221edcd0a86241f86876970f1a64877d3083b39d8e574567f14dea52680538770a37bc70c55d74b66ddab6fda551209c32bb844 SHA512 4d48ec3faf26d046498edccc0dd6007dff36d8346395b5c62b2b85a8ff9bba5ac571cbdcb2aa8e522b6f4c155bd845a416cc715c30a29e8eae6d033ee1b52be7
diff --git a/dev-python/reno/reno-3.5.0.ebuild b/dev-python/reno/reno-3.5.0.ebuild
new file mode 100644
index 000000000000..d05d134d0ba7
--- /dev/null
+++ b/dev-python/reno/reno-3.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.org/project/reno/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+# The doc needs to be built from a git repository
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Some tests need to be run from a git repository
+ rm reno/tests/test_{cache,semver}.py || die
+ distutils-r1_python_prepare_all
+}