summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-29 16:42:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-29 22:43:40 -0500
commit19adfded88fa698aa49dd5310b231e9cb57a3ff5 (patch)
tree1f7c14336a06f1350c52b08df7a9d1c9e3cbf612 /dev-python/reno
parentsci-libs/blas-reference: ebuild maintenance, cleanup (diff)
downloadgentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.gz
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.bz2
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.zip
add initial support for newton (keystone)
dropped py3.3 and updated most (maybe all) to eapi6
Diffstat (limited to 'dev-python/reno')
-rw-r--r--dev-python/reno/Manifest1
-rw-r--r--dev-python/reno/reno-1.8.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/reno/Manifest b/dev-python/reno/Manifest
index 79f09ae23a59..5a83e2805fb5 100644
--- a/dev-python/reno/Manifest
+++ b/dev-python/reno/Manifest
@@ -1 +1,2 @@
DIST reno-1.2.0.tar.gz 23725 SHA256 8f2c4f9b8325e6de4a5a2a98169b2906bd2479cc2c66b97cd6899da455425fd3 SHA512 61abf852504ab9ace324efc70bbe4bf5ce226175a4375f37466ebbe011cb65c7d306d69cd90a5e152f03d60f578be02d57a3805647a486e44dccf59b17595083 WHIRLPOOL 4a25f46b2a3c7693642104402db8bc024c82d19e3d8e3a11c899485aa7acd005a868a31665a0bb827f4922869c08297d63bdba5df76f0bf81cf8b95b2faa35db
+DIST reno-1.8.0.tar.gz 33367 SHA256 fa8e478fe070b6f658fa4868941449cc6dca7b08f520756dcebed2c87e070fdf SHA512 b8254cddd713d85dbbbedfaca864950093a2194e3a2e9754e5fb2490b2434d808dc3ae3659e901df0cf5ce7f33d6bf07d1c39fc086526a127643636199420d64 WHIRLPOOL 3c6e288af413ddf97be057278bec4ecbdda0fd1e80b29f52b20f3ccd6212090e16842e98a50e5dbe65260cb279112d87af3ee00aeb5371bc0dbb374a378e501c
diff --git a/dev-python/reno/reno-1.8.0.ebuild b/dev-python/reno/reno-1.8.0.ebuild
new file mode 100644
index 000000000000..74f321cb075c
--- /dev/null
+++ b/dev-python/reno/reno-1.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.python.org/pypi/reno"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="
+ >=dev-python/pbr-1.4[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]"