summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-04-21 14:18:59 +0200
committerDavid Seifert <soap@gentoo.org>2019-04-21 14:18:59 +0200
commit757121ce5abed563609610918426879c3235f60a (patch)
tree5afca97e08d0043db6c05a5a9e3d66d9180d2324 /dev-python/reportlab/reportlab-3.5.13-r1.ebuild
parentdev-libs/icu-layoutex: Bump to version 64.2 (diff)
downloadgentoo-757121ce5abed563609610918426879c3235f60a.tar.gz
gentoo-757121ce5abed563609610918426879c3235f60a.tar.bz2
gentoo-757121ce5abed563609610918426879c3235f60a.zip
dev-python/reportlab: Add patch for >=pillow-6
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/reportlab/reportlab-3.5.13-r1.ebuild')
-rw-r--r--dev-python/reportlab/reportlab-3.5.13-r1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/reportlab/reportlab-3.5.13-r1.ebuild b/dev-python/reportlab/reportlab-3.5.13-r1.ebuild
new file mode 100644
index 000000000000..77800e21ecca
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.5.13-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} ) # Tests crash with pypy
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="http://www.reportlab.com/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]
+ media-libs/libart_lgpl
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.5.13-disable-network-tests.patch"
+ "${FILESDIR}/${PN}-3.5.13-pillow-VERSION.patch"
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ pushd tests > /dev/null || die
+ "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ if use examples ; then
+ docinto examples
+ dosod -r demos/. tools/pythonpoint/demos
+ fi
+
+ distutils-r1_python_install_all
+}