summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 08:15:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 08:33:34 +0200
commit0c08976624b37c36587bf06fa4a3f773a2f85e26 (patch)
treefd381c036e60eed9847787567afee2f15579131c /dev-python/reportlab
parentdev-python/identify: Bump to 2.2.13 (diff)
downloadgentoo-0c08976624b37c36587bf06fa4a3f773a2f85e26.tar.gz
gentoo-0c08976624b37c36587bf06fa4a3f773a2f85e26.tar.bz2
gentoo-0c08976624b37c36587bf06fa4a3f773a2f85e26.zip
dev-python/reportlab: Bump to 3.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.6.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 895684a9d9d8..600fb03ac910 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -2,3 +2,4 @@ DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f
DIST reportlab-3.5.67.tar.gz 2911726 BLAKE2B 8dbd3bb54c2c651616c3b6be905ac7b43b3a8f30f630d2f9b91882416cb4513751affa507870fdd801b5aa53480498ecc9a5fe3902ab38d72288b6f48ce892e9 SHA512 5a0ec58f0ee925079f3756bac309bd5aaf159118a4ed7ec6467721ead23e5db37839014bb49f1804a0dee4532ce21f9c78adec99ec61a4aeffd957184d489a6c
DIST reportlab-3.5.68.tar.gz 4512985 BLAKE2B b38fea7704fcf08ff25d314286830473b90e75a80bcc65fc7b2cfc4c270347aa7c68f31716e635048428c24bb0ca0afc3d0e22bebedb1d1bc50901c13d278fc4 SHA512 4d41f9d9708d2bd172928985e1e2d22ffcc61d2d6fb21bdf1f3275f9ff576f06e712cd9c9d1707ff364608ad8bed6c30754893a7b142dc3accd6eef8aa19c975
DIST reportlab-3.6.0.tar.gz 4499377 BLAKE2B d72f1fb8c05f192ca7e9a13cbf3142e1b14b4bdd6c6eee7da6bb3e48a08500f2c1aebc671d06c020e1dab6107b0b52490c0c72faa82cba1ac66c03014a6130c1 SHA512 64ca4cf868d6d68432e933176087323c2bba58afe2bf444593831afad2471e07b4f33dbeff02fbef009ae7211ef781b1499d3881f27d583dc36ce1eb8f004c4f
+DIST reportlab-3.6.1.tar.gz 4511585 BLAKE2B 7f435f0f4bd7ef57f6ae54dd1efad339165ae9aff72e5bb5b852f46f766f6e50cb9bda3fcde88489323ec430c76ab59ad69e29b9068e541e76e84a270598d238 SHA512 ecccfb8300493eb0a8b6d1ed51ec8eb0501e74597c62ab498ac6766984d2ee9d1ecb2ce3dcd4ca2d47f5aacce08ff757afd01df995f0aef14ed088ce937616bc
diff --git a/dev-python/reportlab/reportlab-3.6.1.ebuild b/dev-python/reportlab/reportlab-3.6.1.ebuild
new file mode 100644
index 000000000000..b7688f2391ae
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl
+ sys-libs/zlib:="
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]"
+BDEPEND="
+ app-arch/unzip"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests unittest
+
+PATCHES=(
+ # bug 738312, remove -L/usr/lib from link line
+ "${FILESDIR}"/${PN}-3.5.48-usr-lib-LLD.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+src_configure() {
+ DISTUTILS_ARGS=(
+ --no-download-t1-files
+ --use-system-libart
+ )
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py -v || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}