summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-26 14:32:55 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-26 14:32:55 +0100
commit300193b8b0ac5683594ed62351d496df71658df9 (patch)
tree9f94554ce3e63fdc8eba419f7d25324446624a14 /dev-python/reportlab
parentdev-python/django: Remove ia64 keywords (diff)
downloadgentoo-300193b8b0ac5683594ed62351d496df71658df9.tar.gz
gentoo-300193b8b0ac5683594ed62351d496df71658df9.tar.bz2
gentoo-300193b8b0ac5683594ed62351d496df71658df9.zip
dev-python/reportlab: Remove old
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/files/reportlab-no-pip.patch12
-rw-r--r--dev-python/reportlab/reportlab-3.3.0-r2.ebuild72
3 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 1308c593f74d..154a20803204 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,3 +1,2 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
-DIST reportlab-3.3.0.tar.gz 1959255 BLAKE2B 0acd2d306da7836a2324b9a63c158b1b935cd393f5d1eb62cd15f8f4be6e48dac77807d1635ccafc569a47420dc3f4eec49c3ea3852a5a4241b10f0d73550865 SHA512 a6dbe5db13a9e430855ba8139310d8f04ade221c340467c2e0f5bf60c700f17148069358beb057f1667217a09b71ba1ae3112bd02e7c8de00e53a8f852acb8df
DIST reportlab-3.5.13.tar.gz 2842790 BLAKE2B 1457b5eb18d2f294decd7bbee202f42900a443eb7a31c2af56cc2180154e1bb48c4044c499b14489c23210e78c9bafb3fbbcd0c5a28f1d2e25f57d91dcb48526 SHA512 50afcdb5e844cc7ec5c1cf72ca28556e98ad721dce5b20cfb32fa720d56b221b9bd2662a88ea5647b11306d80e653334635b54165daa02d3062cf9d051bbd24b
diff --git a/dev-python/reportlab/files/reportlab-no-pip.patch b/dev-python/reportlab/files/reportlab-no-pip.patch
deleted file mode 100644
index 332878e24dcf..000000000000
--- a/dev-python/reportlab/files/reportlab-no-pip.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/setup.py b/setup.py
---- a/setup.py
-+++ b/setup.py
-@@ -538,7 +538,7 @@
- ],
-
- #this probably only works for setuptools, but distutils seems to ignore it
-- install_requires=['pillow>=2.4.0','pip>=1.4.1', 'setuptools>=2.2'],
-+ install_requires=['pillow>=2.4.0'],
- )
- print()
- print('########## SUMMARY INFO #########')
diff --git a/dev-python/reportlab/reportlab-3.3.0-r2.ebuild b/dev-python/reportlab/reportlab-3.3.0-r2.ebuild
deleted file mode 100644
index 6d6b1de3fa60..000000000000
--- a/dev-python/reportlab/reportlab-3.3.0-r2.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_6} ) # Tests crash with pypy
-
-inherit distutils-r1 flag-o-matic prefix
-
-DESCRIPTION="Tools for generating printable PDF documents from any data source"
-HOMEPAGE="http://www.reportlab.com/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
- http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-RDEPEND="
- <dev-python/pillow-6[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]
- media-libs/libart_lgpl
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-2.2[${PYTHON_USEDEP}]
- app-arch/unzip
-"
-
-PATCHES=(
- "${FILESDIR}"/reportlab-no-pip.patch
-)
-
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${P}/src/reportlab/fonts || die
- unpack pfbfer-20070710.zip
-}
-
-python_prepare_all() {
- sed -i \
- -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
- -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
- src/reportlab/rl_config.py || die
-
- eprefixify setup.py
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_compile() {
- if ! python_is_python3; then
- local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
- fi
- distutils-r1_python_compile
-}
-
-python_test() {
- pushd tests > /dev/null || die
- "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- use examples && local EXAMPLES=( demos/. tools/pythonpoint/demos )
-
- distutils-r1_python_install_all
-}