summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-22 01:20:41 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-22 01:20:41 +0200
commit420bf4ec987bdb21ac66a246b7912a05b8b0e234 (patch)
tree92f30f914dde3611b631365769327876dacd2766 /dev-python/reportlab
parentdev-python/pygraphviz: Version bump to 1.6 (diff)
downloadgentoo-420bf4ec987bdb21ac66a246b7912a05b8b0e234.tar.gz
gentoo-420bf4ec987bdb21ac66a246b7912a05b8b0e234.tar.bz2
gentoo-420bf4ec987bdb21ac66a246b7912a05b8b0e234.zip
dev-python/reportlab: Version bump to 3.5.48
Closes: https://bugs.gentoo.org/738312 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch34
-rw-r--r--dev-python/reportlab/reportlab-3.5.48.ebuild63
3 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 200e6e1d0aa9..2585b56ae434 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -1,2 +1,3 @@
DIST pfbfer-20070710.zip 677333 BLAKE2B 100214476a361a5e5d1f3da0999591345f6e3a3f8c6bc3f6a3e9eca734190c6259758a43302c6e41254d33491fe535eb7d5dd07aa9727c912424bebc31fc18df SHA512 6fd4a5d955464b10d13a7b748703450c1fe120d5ed09e8cfa1b4dfa9c183c59fe001df29433af551796b0df62544b7ddc364f9bb1bdcc2cd300434340ffcc4f2
DIST reportlab-3.5.42.tar.gz 2883081 BLAKE2B 22f4e7ebc233895a036eeb94c5beb9206be561a8a44895b36291a4f840603a2fec90107ac60e749f99be629202801c63ff67d5034d19b42383f2df12d457104d SHA512 f52717867190bf7812fd566d9ec3044198db809cdd0f53cc9dbfa92503a202540db659369e20bba3de07cd28eb10515d03b85700ac138c9394dc9eed1f08b8f8
+DIST reportlab-3.5.48.tar.gz 2890211 BLAKE2B bf0cde9b9e80459caee37949dc90a777a56da5d2c8e6dde09bddbdac2f2c55031d92b3c7c6346b6f563904525020c0e4f666b5e2effdd761c81412df21ec60eb SHA512 ce31cb7e9e2226cb6d59d446f90c1df94f0f84077d298f7ba862f5c75995afa20fa077b1ee1ab9a145c9276cee0d75fe61237e001ad0e5b96dfb0027adff3db7
diff --git a/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch b/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch
new file mode 100644
index 000000000000..09ae9675eb58
--- /dev/null
+++ b/dev-python/reportlab/files/reportlab-3.5.48-usr-lib-LLD.patch
@@ -0,0 +1,34 @@
+--- a/setup.py
++++ b/setup.py
+@@ -163,22 +163,6 @@
+ if self.L is None:
+ L = []
+ I = []
+- if platform == "cygwin":
+- aDir(L, os.path.join("/usr/lib", "python%s" % sys.version[:3], "config"))
+- elif platform == "darwin":
+- # attempt to make sure we pick freetype2 over other versions
+- aDir(I, "/sw/include/freetype2")
+- aDir(I, "/sw/lib/freetype2/include")
+- # fink installation directories
+- aDir(L, "/sw/lib")
+- aDir(I, "/sw/include")
+- # darwin ports installation directories
+- aDir(L, "/opt/local/lib")
+- aDir(I, "/opt/local/include")
+- aDir(I, "/usr/local/include")
+- aDir(L, "/usr/local/lib")
+- aDir(I, "/usr/include")
+- aDir(L, "/usr/lib")
+ aDir(I, "/usr/include/freetype2")
+ prefix = sysconfig.get_config_var("prefix")
+ if prefix:
+@@ -574,7 +558,7 @@
+ SOURCES,
+ include_dirs=[RENDERPM,LIBART_INC,GT1_DIR]+FT_INC_DIR,
+ define_macros=FT_MACROS+[('LIBART_COMPILATION',None)]+debug_macros+[('LIBART_VERSION',LIBART_VERSION)],
+- library_dirs=[]+FT_LIB_DIR,
++ library_dirs=[],
+
+ # libraries to link against
+ libraries=FT_LIB+LIBART_LIB,
diff --git a/dev-python/reportlab/reportlab-3.5.48.ebuild b/dev-python/reportlab/reportlab-3.5.48.ebuild
new file mode 100644
index 000000000000..b32a1a8b141f
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.5.48.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/
+ https://bitbucket.org/rptlab/reportlab/"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl:=
+ sys-libs/zlib:="
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]"
+BDEPEND="
+ test? ( ${RDEPEND} )
+ app-arch/unzip"
+
+distutils_enable_sphinx docs/source
+
+PATCHES=(
+ # bug 738312, remove -L/usr/lib from link line
+ "${FILESDIR}"/${PN}-3.5.48-usr-lib-LLD.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ # tests requiring Internet access
+ sed -i -e 's:test0:_&:' \
+ tests/test_platypus_general.py \
+ tests/test_platypus_images.py || die
+ sed -i -e 's:test9:_&:' tests/test_lib_utils.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}