summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-15 08:19:41 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-15 08:32:06 +0200
commit770c81ccbb06ad49bb9e22b086c7aa5aac42b123 (patch)
treedd40785f93fd80eb8e95e2be7cfb90d0e7834447 /dev-python/requests-cache
parentdev-python/py-cpuinfo: Bump to 8.0.0 (diff)
downloadgentoo-770c81ccbb06ad49bb9e22b086c7aa5aac42b123.tar.gz
gentoo-770c81ccbb06ad49bb9e22b086c7aa5aac42b123.tar.bz2
gentoo-770c81ccbb06ad49bb9e22b086c7aa5aac42b123.zip
dev-python/requests-cache: Bump to 0.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-cache')
-rw-r--r--dev-python/requests-cache/Manifest1
-rw-r--r--dev-python/requests-cache/requests-cache-0.6.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 4bbb2d044a75..845cbc1a369e 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,3 +1,4 @@
DIST requests-cache-0.5.2.tar.gz 31159 BLAKE2B 4fca146a751064baf70954a71df64dbb7f8c9a4e27fec5dbea3620496ce78e7ccfb3785fb63705f513ff6fa938376b0c6acc4a2f584856060b1bc8388517df46 SHA512 355cc571a46b768615606a907a69ed065b3c4b5e74bb6c311abc7a28d9406f32fdea1db0dfd2b1c32dcdc82ed817ef7e0b30086c069de57307254617604c5177
DIST requests-cache-0.6.0.tar.gz 52342 BLAKE2B 12af89721fcf1ae2e4ab14d7ac377f119ef312c64d3b9e5d80a36f26f3a9a798cf090835ee2c9bf886d0baa9b472f4c439d5a032573d442feecbbad930c239fd SHA512 b5b32b9cb99ec51cee67defde715df66b7c50a26f4124cbaf893685048fe188af0cf664232150e3b4fafe3b7a927716966efafadd711be01118d67ad802acef6
DIST requests-cache-0.6.1.gh.tar.gz 47919 BLAKE2B 022fd94a332feae043cf646cefc368fdb6ca1833dcd58621a07425bfb0d7bcb5ff9913c8b53f2bc0769fd23e8f364c437ee10f16fd37d1d340e8c46bcba9d53e SHA512 f8bea03b05b2f1e55fe6c975b5f5caacff55250d81f41cf953052c77101fc726ff39f9d95e1fd2829ddb59215226026bdddfd93918feb478395375ac0e0a4439
+DIST requests-cache-0.6.2.gh.tar.gz 47962 BLAKE2B f0597f3c5f4a678b94f3b15023e3aba5247de3d79043e7e1cbd4ab0f2d4457e2f5feab130665129ae87baba56576312b1420ae16c2a34b44dc780bf05351615c SHA512 c97119127b1e80e6eec02938b2e0e8de785875f46d348215e05ee2d668feb77ed40f0dad4ed4a3ae53fb8e6708c8d7b13788e54694a38cef3ce22e83f13f97e2
diff --git a/dev-python/requests-cache/requests-cache-0.6.2.ebuild b/dev-python/requests-cache/requests-cache-0.6.2.ebuild
new file mode 100644
index 000000000000..dd9fdcadae1e
--- /dev/null
+++ b/dev-python/requests-cache/requests-cache-0.6.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+HOMEPAGE="
+ https://pypi.org/project/requests-cache/
+ https://github.com/reclosedev/requests-cache/"
+DESCRIPTION="Persistent cache for requests library"
+SRC_URI="
+ https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/itsdangerous[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpbin[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ local skipped_tests=(
+ # These require extra servers running
+ tests/integration/test_dynamodb.py
+ tests/integration/test_gridfs.py
+ tests/integration/test_mongodb.py
+ tests/integration/test_redis.py
+
+ # TODO
+# 'tests/integration/test_cache.py::test_all_response_formats[json]'
+ )
+
+ local -x USE_PYTEST_HTTPBIN=true
+ epytest ${skipped_tests[@]/#/--deselect }
+}