summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:04:09 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:26:43 +0300
commit57757b58487389ee79c10dcd6b3d2827be382c2d (patch)
treefd1e7aa6631d67cf2fc59b9b9c32061aadb8247c /dev-python/requests-file
parentdev-python/requests-futures: enable py3.11 (diff)
downloadgentoo-57757b58487389ee79c10dcd6b3d2827be382c2d.tar.gz
gentoo-57757b58487389ee79c10dcd6b3d2827be382c2d.tar.bz2
gentoo-57757b58487389ee79c10dcd6b3d2827be382c2d.zip
dev-python/requests-file: EAPI=8, USE pep517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/requests-file')
-rw-r--r--dev-python/requests-file/requests-file-1.5.1-r2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/requests-file/requests-file-1.5.1-r2.ebuild b/dev-python/requests-file/requests-file-1.5.1-r2.ebuild
new file mode 100644
index 000000000000..26a8b97f4dcd
--- /dev/null
+++ b/dev-python/requests-file/requests-file-1.5.1-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="File transport adapter for Requests"
+HOMEPAGE="https://pypi.org/project/requests-file/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest