summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:01:50 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:26:42 +0300
commit9749b86460a4134c56baf580b6cec5eeaf1814fd (patch)
tree559f57aebe58bf5f04c17d17d0aa03cec9ca5957 /dev-python/requests-futures
parentdev-python/retrying: EAPI=8, USE pep517 (diff)
downloadgentoo-9749b86460a4134c56baf580b6cec5eeaf1814fd.tar.gz
gentoo-9749b86460a4134c56baf580b6cec5eeaf1814fd.tar.bz2
gentoo-9749b86460a4134c56baf580b6cec5eeaf1814fd.zip
dev-python/requests-futures: EAPI=8, USE pep517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/requests-futures')
-rw-r--r--dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild b/dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..0e4703098f5d
--- /dev/null
+++ b/dev-python/requests-futures/requests-futures-1.0.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Asynchronous Python HTTP for Humans"
+HOMEPAGE="https://github.com/ross/requests-futures"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND=">=dev-python/requests-1.2.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # known failures by upstream
+ # https://github.com/ross/requests-futures/issues/94
+ test_requests_futures.py::RequestsTestCase::test_redirect
+ test_requests_futures.py::RequestsProcessPoolTestCase::test_futures_existing_session
+ test_requests_futures.py::RequestsProcessPoolTestCase::test_futures_session
+)