summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-03 11:40:30 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-03 11:49:24 +0200
commit61c4b3f5e66f1002a944babe577d87f1d9f310c0 (patch)
tree4610a1f1c0bb752f3893644e4ebc1493c16d2eaa /dev-python/requests-mock
parentsys-kernel/gentoo-sources: add 6.0.0 and genpatches (diff)
downloadgentoo-61c4b3f5e66f1002a944babe577d87f1d9f310c0.tar.gz
gentoo-61c4b3f5e66f1002a944babe577d87f1d9f310c0.tar.bz2
gentoo-61c4b3f5e66f1002a944babe577d87f1d9f310c0.zip
dev-python/requests-mock: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-mock')
-rw-r--r--dev-python/requests-mock/Manifest1
-rw-r--r--dev-python/requests-mock/files/requests-mock-1.9.3-obj-has-no-attr-url.patch50
-rw-r--r--dev-python/requests-mock/requests-mock-1.9.3-r1.ebuild49
3 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/requests-mock/Manifest b/dev-python/requests-mock/Manifest
index e39e81034682..5bc4b0672627 100644
--- a/dev-python/requests-mock/Manifest
+++ b/dev-python/requests-mock/Manifest
@@ -1,2 +1 @@
DIST requests-mock-1.10.0.tar.gz 72627 BLAKE2B 4ce1838f03b732de4007c2e9b700876dcf8dba0f5eafef1292e0e40ae75e08f9b3bf74c3620d2d762944ccf9af248304929f57a337122b1a69d13355dc3f290e SHA512 873c9b219e2a2360872fac22c83371ce40f4dee45e6a0d40365f4f551271c2168a662dced6e8baad890b1dadfc03d21d4ce013f149d25a42d998af4f4fca2a79
-DIST requests-mock-1.9.3.tar.gz 67988 BLAKE2B 8ab651adbde9e18370641655589f5d209d2a9ae07d82108c64e4269757217cf01588066ebc3005852cf48527f911d3fb76cedce3e88bc74123db81725b4b5865 SHA512 bcded541d78670a1b1fc87f97d35286ab4bafd6946beb9d9b44886454c26a4d8c05834add18914f3f72b1d3c0534311efd1cc80e711b5085eb63053ae24cbb6f
diff --git a/dev-python/requests-mock/files/requests-mock-1.9.3-obj-has-no-attr-url.patch b/dev-python/requests-mock/files/requests-mock-1.9.3-obj-has-no-attr-url.patch
deleted file mode 100644
index d43b0b41e65a..000000000000
--- a/dev-python/requests-mock/files/requests-mock-1.9.3-obj-has-no-attr-url.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From 7238c1148c756e6a27c3dbc1ccbff7a3e9a60d82 Mon Sep 17 00:00:00 2001
-From: Jamie Lennox <jamielennox@gmail.com>
-Date: Fri, 28 May 2021 09:33:25 +0700
-Subject: [PATCH] Fix failing pytest
-
-When you start a method with test_ pytest loads it and tries to parse
-the parameters as fixtures. In this case it's not a real test, just a
-matcher function used later on in the test file.
-
-We can inline it into the function as it's only used in one place.
-
-Fixes: #175
----
- tests/test_custom_matchers.py | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/tests/test_custom_matchers.py b/tests/test_custom_matchers.py
-index d49f72a..546a63e 100644
---- a/tests/test_custom_matchers.py
-+++ b/tests/test_custom_matchers.py
-@@ -31,13 +31,6 @@ def match_all(request):
- return requests_mock.create_response(request, content=six.b('data'))
-
-
--def test_a(request):
-- if 'a' in request.url:
-- return match_all(request)
--
-- return None
--
--
- class CustomMatchersTests(base.TestCase):
-
- def assertMatchAll(self, resp):
-@@ -65,7 +58,14 @@ def test_failing_matcher(self, mocker):
-
- @requests_mock.Mocker()
- def test_some_pass(self, mocker):
-- mocker.add_matcher(test_a)
-+
-+ def matcher_a(request):
-+ if 'a' in request.url:
-+ return match_all(request)
-+
-+ return None
-+
-+ mocker.add_matcher(matcher_a)
-
- resp = requests.get('http://any/thing')
- self.assertMatchAll(resp)
diff --git a/dev-python/requests-mock/requests-mock-1.9.3-r1.ebuild b/dev-python/requests-mock/requests-mock-1.9.3-r1.ebuild
deleted file mode 100644
index f6ab5d2b33d0..000000000000
--- a/dev-python/requests-mock/requests-mock-1.9.3-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-DISTUTILS_USE_PEP517=setuptools
-inherit distutils-r1
-
-DESCRIPTION="Mock out responses from the requests package"
-HOMEPAGE="https://github.com/jamielennox/requests-mock"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/requests-2.3[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
- test? (
- dev-python/fixtures[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-obj-has-no-attr-url.patch"
-)
-
-distutils_enable_sphinx doc/source
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # Disable reno which only works inside a git repository
- sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
- # Remove the release notes section which requires reno
- rm doc/source/release-notes.rst || die
- sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
- # Disable a test which requires purl (not in the tree)
- sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
- tests/test_adapter.py || die
- distutils-r1_python_prepare_all
-}