summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2016-08-13 07:07:51 +0200
committerJohann Schmitz <ercpe@gentoo.org>2016-08-13 07:07:51 +0200
commitb4da8d5f73eb06e9f7738ed0f759049e40ed6ae6 (patch)
treea963160068df53fb9f96315af8e3fb18135ea145 /dev-python/requests-oauthlib/requests-oauthlib-0.6.2.ebuild
parentnet-firewall/shorewall: Cleanup (diff)
downloadgentoo-b4da8d5f73eb06e9f7738ed0f759049e40ed6ae6.tar.gz
gentoo-b4da8d5f73eb06e9f7738ed0f759049e40ed6ae6.tar.bz2
gentoo-b4da8d5f73eb06e9f7738ed0f759049e40ed6ae6.zip
dev-python/requests-oauthlib: Version bump to 0.6.2 (bug #565590)
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/requests-oauthlib/requests-oauthlib-0.6.2.ebuild')
-rw-r--r--dev-python/requests-oauthlib/requests-oauthlib-0.6.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/requests-oauthlib/requests-oauthlib-0.6.2.ebuild b/dev-python/requests-oauthlib/requests-oauthlib-0.6.2.ebuild
new file mode 100644
index 000000000000..d994bbc35ef6
--- /dev/null
+++ b/dev-python/requests-oauthlib/requests-oauthlib-0.6.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for Requests"
+HOMEPAGE="https://github.com/requests/requests-oauthlib"
+SRC_URI="https://github.com/requests/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]"
+
+#Refrain from a doc build for now
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_test() {
+ esetup.py test
+}