summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2019-12-25 19:19:45 +0800
committerJason Zaman <perfinion@gentoo.org>2019-12-26 10:40:09 +0800
commit743b7b310a3cf128e94f73a1ea5042e52cf12e57 (patch)
treeda0237c7402d5a63ec18672f1f156e94ab4e775d /dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild
parentsci-libs/scipy: bump 1.4.1 (diff)
downloadgentoo-743b7b310a3cf128e94f73a1ea5042e52cf12e57.tar.gz
gentoo-743b7b310a3cf128e94f73a1ea5042e52cf12e57.tar.bz2
gentoo-743b7b310a3cf128e94f73a1ea5042e52cf12e57.zip
dev-python/requests-oauthlib: bump 1.3.0
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Jason Zaman <perfinion@gentoo.org>
Diffstat (limited to 'dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild')
-rw-r--r--dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild b/dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild
new file mode 100644
index 000000000000..91925c019e91
--- /dev/null
+++ b/dev-python/requests-oauthlib/requests-oauthlib-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="This project provides first-class OAuth library support for Requests"
+HOMEPAGE="https://github.com/requests/requests-oauthlib"
+SRC_URI="https://github.com/requests/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="ISC"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# tests fail with network-sandbox
+RESTRICT="!test? ( test )
+ test"
+
+DEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oauthlib-0.6.2[${PYTHON_USEDEP}]"
+
+#Refrain from a doc build for now
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_test() {
+ esetup.py test
+}