summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-10-07 08:37:10 +0200
committerMichał Górny <mgorny@gentoo.org>2022-10-07 08:40:29 +0200
commit4f2438a58ef297306bf3becc7eb23cd29cd4fffd (patch)
treebf81658c40cca871c23c42c79b909ecd91818552 /dev-python/requests-toolbelt
parentdev-python/black: Bump to 22.10.0 (diff)
downloadgentoo-4f2438a58ef297306bf3becc7eb23cd29cd4fffd.tar.gz
gentoo-4f2438a58ef297306bf3becc7eb23cd29cd4fffd.tar.bz2
gentoo-4f2438a58ef297306bf3becc7eb23cd29cd4fffd.zip
dev-python/requests-toolbelt: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests-toolbelt')
-rw-r--r--dev-python/requests-toolbelt/Manifest1
-rw-r--r--dev-python/requests-toolbelt/requests-toolbelt-0.10.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/requests-toolbelt/Manifest b/dev-python/requests-toolbelt/Manifest
index 619cd63f19ca..e3ed802a1046 100644
--- a/dev-python/requests-toolbelt/Manifest
+++ b/dev-python/requests-toolbelt/Manifest
@@ -1 +1,2 @@
+DIST requests-toolbelt-0.10.0.tar.gz 211210 BLAKE2B 73196e33d42ff6f4532cd2904537451cc237627a149fa759fca7a66e360c0ddb8baf8c4537c880baf03a25065226380788449bae05434aad37962034e1324acb SHA512 75e3a3e609625254e1f078d3c48c664b3118f5a406c84e59c4e9acdeb20a79b5d38ceaaf9578920063f063aa8385139310c06331499aaa92d3c51146f908f1a1
DIST requests-toolbelt-0.9.1.tar.gz 207286 BLAKE2B 6123677a9abafebddf7dffde2150b2426b5132ebe0c330ff891322ecc3d69232a5b15a0c66e3e1fb4832dc04f5a636a939613fba041e499e9fbca9814f548c7e SHA512 12229928df5df71cb57bc65ef453dc0e4a2bbe190c1579811b2c2823673bd81aeba856b00000fa20b253d0f0fa4fff55ea1e750794ca3785f71c376b1df7fd93
diff --git a/dev-python/requests-toolbelt/requests-toolbelt-0.10.0.ebuild b/dev-python/requests-toolbelt/requests-toolbelt-0.10.0.ebuild
new file mode 100644
index 000000000000..cffab8d53c1e
--- /dev/null
+++ b/dev-python/requests-toolbelt/requests-toolbelt-0.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A utility belt for advanced users of python-requests"
+HOMEPAGE="
+ https://toolbelt.readthedocs.io/
+ https://github.com/requests/toolbelt/
+ https://pypi.org/project/requests-toolbelt/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/betamax[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( AUTHORS.rst HISTORY.rst README.rst )
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_multipart_encoder.py::TestFileFromURLWrapper::test_no_content_length_header
+ tests/test_multipart_encoder.py::TestFileFromURLWrapper::test_read_file
+ tests/test_multipart_encoder.py::TestMultipartEncoder::test_reads_file_from_url_wrapper
+)
+
+EPYTEST_IGNORE=(
+ # certs have expired
+ # (if you ever fix this, look into git history for proper
+ # cryptography/pyopenssl logic)
+ tests/test_x509_adapter.py
+)