summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-22 16:37:15 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-22 17:21:05 +0100
commitdf1f4a2dfc0c2d77ae20cdcc72dc8102c45fbb2d (patch)
treefa891af19a14ba76cf3e4439713c27259e6ec158 /dev-python/requests/files
parentdev-python/pytest-httpbin: Bump to 1.0.0, fix tests (diff)
downloadgentoo-df1f4a2dfc0c2d77ae20cdcc72dc8102c45fbb2d.tar.gz
gentoo-df1f4a2dfc0c2d77ae20cdcc72dc8102c45fbb2d.tar.bz2
gentoo-df1f4a2dfc0c2d77ae20cdcc72dc8102c45fbb2d.zip
dev-python/requests: Bump to 2.22.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests/files')
-rw-r--r--dev-python/requests/files/requests-2.22.0-pytest-4.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/requests/files/requests-2.22.0-pytest-4.patch b/dev-python/requests/files/requests-2.22.0-pytest-4.patch
new file mode 100644
index 000000000000..5b8ec34912d9
--- /dev/null
+++ b/dev-python/requests/files/requests-2.22.0-pytest-4.patch
@@ -0,0 +1,27 @@
+From dc75b3ca0b4c95648eb07b92cb414394d99c13a0 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Mon, 8 Apr 2019 18:04:22 +0200
+Subject: [PATCH] Support pytest 4
+
+Fixes https://github.com/kennethreitz/requests/issues/5048
+
+See https://docs.pytest.org/en/latest/deprecations.html#marks-in-pytest-mark-parametrize
+---
+ setup.py | 2 +-
+ tests/test_utils.py | 3 ++-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_utils.py b/tests/test_utils.py
+index 59b0b0efa..62c51494d 100644
+--- a/tests/test_utils.py
++++ b/tests/test_utils.py
+@@ -33,7 +33,8 @@ class TestSuperLen:
+ 'stream, value', (
+ (StringIO.StringIO, 'Test'),
+ (BytesIO, b'Test'),
+- pytest.mark.skipif('cStringIO is None')((cStringIO, 'Test')),
++ pytest.param(cStringIO, 'Test',
++ marks=pytest.mark.skipif('cStringIO is None')),
+ ))
+ def test_io_streams(self, stream, value):
+ """Ensures that we properly deal with different kinds of IO streams."""