summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-18 17:37:26 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-18 17:37:26 +0200
commit405a9d60584b059e04703919156a4dcd4d299c40 (patch)
tree7a946eb74c698b8b928f8a787d49f004a5a2e1f3 /dev-python/requests
parentdev-python/requests-cache: Remove old (diff)
downloadgentoo-405a9d60584b059e04703919156a4dcd4d299c40.tar.gz
gentoo-405a9d60584b059e04703919156a4dcd4d299c40.tar.bz2
gentoo-405a9d60584b059e04703919156a4dcd4d299c40.zip
dev-python/requests: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/Manifest1
-rw-r--r--dev-python/requests/requests-2.23.0.ebuild65
2 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index 2bffc9bf3077..e8ddf9c68fe5 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -1,2 +1 @@
-DIST requests-2.23.0.tar.gz 114327 BLAKE2B 75bdf83e117e9f67c2032609ed5c20582f743519ab8364dd6b12685efd6b6e438f1c155fe9d3df87e48608747f59df6d99698d1f68e5df6c0cbced9e7d1a9b37 SHA512 a0f7db5cc9ce67af9f6f81b72e41491735a102f2a1da2fbde98e279846e2140cd26b6370aa5ec79c148c397885a7ae2bbce45c4587215f510dd02b8ac57cb46e
DIST requests-2.24.0.tar.gz 115071 BLAKE2B ae98be1d023b2a7b883e15a7a5d214ecbf482234e9de6bfc9cd06d1f04d1b57d101d41a2c6fdd07b7a6b468875463514841d2e023391ac8ae0797a2cb58b3424 SHA512 46ca8ab70eb39be8398c242404b9b3ffb6baddd5c78eaad125b55c719154eb8c7b6a737a8dc587b0cb51b3b9a074abaa8b2ff347a64d38f4f90cdba4db16a119
diff --git a/dev-python/requests/requests-2.23.0.ebuild b/dev-python/requests/requests-2.23.0.ebuild
deleted file mode 100644
index 28ef5b6c04fe..000000000000
--- a/dev-python/requests/requests-2.23.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="https://requests.readthedocs.io/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="socks5 +ssl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
- <dev-python/chardet-4[${PYTHON_USEDEP}]
- >=dev-python/idna-2.5[${PYTHON_USEDEP}]
- <dev-python/idna-3[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.26[${PYTHON_USEDEP}]
- socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
- ssl? (
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[${PYTHON_USEDEP}]
- )
-"
-
-BDEPEND="
- test? (
- ${RDEPEND}
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
- )
-"
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # strip tests that require some kind of network
- sed -e 's:test_connect_timeout:_&:' \
- -e 's:test_total_timeout_connect:_&:' \
- -i tests/test_requests.py || die
- # probably pyopenssl version dependent
- sed -e 's:test_https_warnings:_&:' \
- -i tests/test_requests.py || die
- # doctests rely on networking
- sed -e 's:--doctest-modules::' \
- -i pytest.ini || die
-}
-
-python_test() {
- # tests hang with pypy & pypy3
-# [[ ${EPYTHON} == pypy* ]] && continue
-
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}