summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-31 07:32:28 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-31 08:20:54 +0200
commitcf069ca483d04ddf820004fa13cda9883b1d308c (patch)
tree930a36b13590874bcd6e27c2c92f8599851a969d /dev-python/requests
parentdev-python/matplotlib: Remove old (diff)
downloadgentoo-cf069ca483d04ddf820004fa13cda9883b1d308c.tar.gz
gentoo-cf069ca483d04ddf820004fa13cda9883b1d308c.tar.bz2
gentoo-cf069ca483d04ddf820004fa13cda9883b1d308c.zip
dev-python/requests: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/Manifest1
-rw-r--r--dev-python/requests/requests-2.21.0-r1.ebuild53
2 files changed, 0 insertions, 54 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index b6aa08a4a641..2bffc9bf3077 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -1,3 +1,2 @@
-DIST requests-2.21.0.tar.gz 111528 BLAKE2B 7b40f9f572a8efde41c177fb5d1e1eaf29ca60cad0661fa28ac0085f3700348380d619f68c0082f24044d1af82b16d6b1e7d5dd2c2a2329f85fcee7141b1fbf6 SHA512 385e1d80993a21c09e7c4682500ca8c24155962ba41ecd8e73612722b2ff6618b736e827fc48ad1683b0d2bc7a420cfe680f5107860aca52656ef777f1d60104
DIST requests-2.23.0.tar.gz 114327 BLAKE2B 75bdf83e117e9f67c2032609ed5c20582f743519ab8364dd6b12685efd6b6e438f1c155fe9d3df87e48608747f59df6d99698d1f68e5df6c0cbced9e7d1a9b37 SHA512 a0f7db5cc9ce67af9f6f81b72e41491735a102f2a1da2fbde98e279846e2140cd26b6370aa5ec79c148c397885a7ae2bbce45c4587215f510dd02b8ac57cb46e
DIST requests-2.24.0.tar.gz 115071 BLAKE2B ae98be1d023b2a7b883e15a7a5d214ecbf482234e9de6bfc9cd06d1f04d1b57d101d41a2c6fdd07b7a6b468875463514841d2e023391ac8ae0797a2cb58b3424 SHA512 46ca8ab70eb39be8398c242404b9b3ffb6baddd5c78eaad125b55c719154eb8c7b6a737a8dc587b0cb51b3b9a074abaa8b2ff347a64d38f4f90cdba4db16a119
diff --git a/dev-python/requests/requests-2.21.0-r1.ebuild b/dev-python/requests/requests-2.21.0-r1.ebuild
deleted file mode 100644
index 6151447ebb1a..000000000000
--- a/dev-python/requests/requests-2.21.0-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="https://requests.readthedocs.io/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="socks5 +ssl"
-
-RDEPEND="
- >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
- <dev-python/chardet-3.1.0[${PYTHON_USEDEP}]
- >=dev-python/idna-2.5[${PYTHON_USEDEP}]
- <dev-python/idna-2.9[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.25[${PYTHON_USEDEP}]
- socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
- ssl? (
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-0.14[$(python_gen_usedep 'python*' pypy)]
- )
-"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-# tests connect to various remote sites
-RESTRICT="test"
-
-#DEPEND+="
-# test? (
-# dev-python/pytest[${PYTHON_USEDEP}]
-# dev-python/pytest-httpbin[${PYTHON_USEDEP}]
-# dev-python/pytest-mock[${PYTHON_USEDEP}]
-# dev-python/pytest-xdist[${PYTHON_USEDEP}]
-# >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
-# )
-#"
-
-python_test() {
- py.test || die
-}