summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2019-12-07 12:48:19 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-07 13:55:29 -0800
commitc8b4ce9747e3f7e2edb14ed6fb80d1104c72e6f1 (patch)
treeaf281dfaeda56da6ac7d1ea88a52661e0a072a81 /dev-python/requests_download/requests_download-0.1.2.ebuild
parentdev-python/flit_core: New package (diff)
downloadgentoo-c8b4ce9747e3f7e2edb14ed6fb80d1104c72e6f1.tar.gz
gentoo-c8b4ce9747e3f7e2edb14ed6fb80d1104c72e6f1.tar.bz2
gentoo-c8b4ce9747e3f7e2edb14ed6fb80d1104c72e6f1.zip
dev-python/requests_download: New package
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/requests_download/requests_download-0.1.2.ebuild')
-rw-r--r--dev-python/requests_download/requests_download-0.1.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/requests_download/requests_download-0.1.2.ebuild b/dev-python/requests_download/requests_download-0.1.2.ebuild
new file mode 100644
index 000000000000..231d3877ce3c
--- /dev/null
+++ b/dev-python/requests_download/requests_download-0.1.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A convenient function to download to a file using requests"
+HOMEPAGE="https://github.com/takluyver/requests_download https://pypi.org/project/requests_download/"
+SRC_URI="https://github.com/takluyver/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+# there are no tests upstream
+RESTRICT="test"
+
+DOCS=( README.rst )
+
+python_prepare_all() {
+ printf -- "from setuptools import setup\nsetup(name='%s',version='%s',py_modules=['%s'])" \
+ "${PN}" "${PV}" "${PN}" > setup.py || die
+
+ distutils-r1_python_prepare_all
+}