summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-15 22:38:22 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-15 22:38:22 -0600
commitcb1ea1455532aa7ba09a6ed64584e3bb6cb75232 (patch)
tree8ca47a67fca9c5946e6892e40448bbf36b69cd18 /dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
parentdev-python/mox3: 0.24.0 bup (diff)
downloadgentoo-cb1ea1455532aa7ba09a6ed64584e3bb6cb75232.tar.gz
gentoo-cb1ea1455532aa7ba09a6ed64584e3bb6cb75232.tar.bz2
gentoo-cb1ea1455532aa7ba09a6ed64584e3bb6cb75232.zip
dev-python/requestsexceptions: 1.4.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild')
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
new file mode 100644
index 000000000000..8161b92f7bcb
--- /dev/null
+++ b/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Finds the correct path to exceptions in the requests library."
+HOMEPAGE="https://github.com/openstack-infra/requestsexceptions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"