summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-25 09:06:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-25 09:08:40 +0200
commit555bb36885b5bb29e40b60fcd3b11ed2b38a508c (patch)
tree7ae4976416af38386cf8b5b4b208bc01e80c4a62 /dev-python/resolvelib/resolvelib-0.7.1.ebuild
parentdev-python/nltk: Remove old (diff)
downloadgentoo-555bb36885b5bb29e40b60fcd3b11ed2b38a508c.tar.gz
gentoo-555bb36885b5bb29e40b60fcd3b11ed2b38a508c.tar.bz2
gentoo-555bb36885b5bb29e40b60fcd3b11ed2b38a508c.zip
dev-python/resolvelib: Bump to 0.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/resolvelib/resolvelib-0.7.1.ebuild')
-rw-r--r--dev-python/resolvelib/resolvelib-0.7.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/resolvelib/resolvelib-0.7.1.ebuild b/dev-python/resolvelib/resolvelib-0.7.1.ebuild
new file mode 100644
index 000000000000..c9746c36a67b
--- /dev/null
+++ b/dev-python/resolvelib/resolvelib-0.7.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="provides a Resolver class that includes dependency resolution logic"
+HOMEPAGE="https://github.com/sarugaku/resolvelib/"
+SRC_URI="
+ https://github.com/sarugaku/resolvelib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/commentjson[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest