summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-30 05:30:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-30 05:35:58 +0200
commit0bf2a1d211448f59160465e3d4cd44d787416100 (patch)
treec292c946de6a838e430cabe14fcabc6053513d74 /dev-python/responses/responses-0.12.0.ebuild
parentdev-python/ipython: Bump to 7.18.1 (diff)
downloadgentoo-0bf2a1d211448f59160465e3d4cd44d787416100.tar.gz
gentoo-0bf2a1d211448f59160465e3d4cd44d787416100.tar.bz2
gentoo-0bf2a1d211448f59160465e3d4cd44d787416100.zip
dev-python/responses: Bump to 0.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/responses/responses-0.12.0.ebuild')
-rw-r--r--dev-python/responses/responses-0.12.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/responses/responses-0.12.0.ebuild b/dev-python/responses/responses-0.12.0.ebuild
new file mode 100644
index 000000000000..6b113d33a72c
--- /dev/null
+++ b/dev-python/responses/responses-0.12.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility for mocking out the Python Requests library"
+HOMEPAGE="https://github.com/getsentry/responses"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/requests-2.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.10[${PYTHON_USEDEP}]
+ dev-python/cookies[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest